【PAT甲级A1125】 Chain the Ropes (25分)(c++)

1125 Chain the Ropes (25分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:200 ms
内存限制:64 MB

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

在这里插入图片描述

Your job is to make the longest possible rope out of N given segments.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​ ). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4.

Output Specification:
For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意:

将两根绳子对折和在一起能获得一根新的绳子,新绳子同样可以再对折和其他绳子合成一根,求将所给的绳子和到一起的最大长度。

思路:

新绳子的长度是两根绳子对半分的和,每加一根绳子都要将之前的绳子再对半分以下,所以要让长绳子对半分的竟可能少,那就从小到大开始并绳子。

参考代码:

#include <iostream>
#include <algorithm>
#include <vector>

using namespace std;

int main() {
    int n, sum = 0;
    scanf("%d", &n);
    vector<double> v(n);
    for (int i = 0; i < n; i++)
        scanf("%lf", &v[i]);
    sort(v.begin(), v.end());
    sum = v[0];
    for (int i = 1; i < n; i++) {
        sum = (sum + v[i]) / 2;
    }
    printf("%d", sum);
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值