杭电acm 5038 Grade(桶排序)

Grade
Time Limit: 3000/1500 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2772    Accepted Submission(s): 1034


Problem Description
Ted is a employee of Always Cook Mushroom (ACM). His boss Matt gives him a pack of mushrooms and ask him to grade each mushroom according to its weight. Suppose the weight of a mushroom is w, then it’s grade s is

s = 10000 - (100 - w)^2

What’s more, Ted also has to report the mode of the grade of these mushrooms. The mode is the value that appears most often. Mode may not be unique. If not all the value are the same but the frequencies of them are the same, there is no mode.
 

Input
The first line of the input contains an integer T, denoting the number of testcases. Then T test cases follow.

The first line of each test cases contains one integers N (1<=N<=10^6),denoting the number of the mushroom.

The second line contains N integers, denoting the weight of each mushroom. The weight is greater than 0, and less than 200.
 

Output
For each test case, output 2 lines.

The first line contains "Case #x:", where x is the case number (starting from 1)

The second line contains the mode of the grade of the given mushrooms. If there exists multiple modes, output them in ascending order. If there exists no mode, output “Bad Mushroom”.
 

Sample Input

3
6
100 100 100 99 98 101
6
100 100 100 99 99 101
6
100 100 98 99 99 97

 

Sample Output

Case #1:
10000
Case #2:
Bad Mushroom
Case #3:
9999 10000

 

Source

2014 ACM/ICPC Asia Regional Beijing Online

想法:

首先想到0<=w<=200所以(100 - w)的绝对值小于110,大于等于0.

然后我们的统计它们出现次数并要要排序

所以很容易想到桶排序(注意输入数据可以是10的6次方,数组开的大些)。

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int a[1000010];
int b[110];
int main()
{
    int N;
    scanf("%d",&N);
    int z=1;
    while(N--)
    {
     int i,j,n;
     memset(b,0,sizeof(b));
     scanf("%d",&n);
     for(i=0;i<n;i++)
     {
         scanf("%d",&a[i]);
         a[i]=abs(a[i]-100);
         b[a[i]]++;
    }
    int maxx=0;
    for(i=0;i<110;i++)
    {
        if(b[i]>maxx)
            maxx=b[i];
    }
    int count=0;
    for(i=0;i<110;i++)
    {
        if(b[i]==maxx)
            count++;
    }
     printf("Case #%d:\n",z++);
    if(count*maxx==n&&count!=1)
    {
        printf("Bad Mushroom\n");
    }
    else
    {
        int flag=0;
        for(i=109;i>=0;i--)
        {
            if(b[i]==maxx&&flag==0)
               {
                 printf("%d",10000 - (i*i));
                 flag=1;
               }
            else
            if(b[i]==maxx&&flag==1)
             {
                 printf(" %d",10000 -( i*i));
            }
        }
        printf("\n");
    }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值