POJ 3252Round Numbers(数位dp)

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13786 Accepted: 5421

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source

想法:
这题的约束就是一个数的二进制中0的数量要不能少于1的数量,通过上一题,这题状态就很简单了,dp[pos][num],到当前数位pos,0的数量减去1的数量为num的方案数,一个简单的问题,中间某个pos位上num可能为负数(这不一定是非法的,因为我还没枚举完嘛,只要最终的num>=0才能判合法,中途某个pos就不一定了),这里比较好处理,Hash嘛,最小就-32吧(好像),直接加上32,把32当0用。这题主要是要想讲一下lead的用法,显然我要统计0的数量,前导零是有影响的。至于!lead&&!limit才能dp,都是类似的,自己慢慢体会吧。
代码:
#include<stdio.h>
#include<string.h>
int a[35];
int dp[35][55];
int dfs(int pos,int sum,bool lead,bool limit)
{
    if(pos<0)
        return sum>=32;
    if(!limit &&!lead&& dp[pos][sum] != -1)
        return dp[pos][sum];
    int up = limit ? a[pos] : 1;
    int tmp = 0;
    for(int i = 0; i <= up; i++)
    {
        if(lead&&i==0)
            tmp += dfs(pos-1,sum,lead,limit&&(i==a[pos]));
        else
            tmp += dfs(pos-1,sum+(i==0?1:-1),lead&&i==0,limit&&(i==a[pos]));
    }
    if(!limit&&!lead)
        dp[pos][sum] = tmp;
    return tmp;


}
int solver(int x)
{
    int pos=0;
    while(x)
    {
     a[pos++]=x&1;
     x>>=1;
    }
  return  dfs(pos-1,32,1,1);
}
int main()
{
    int n,m;
    memset(dp,-1,sizeof(dp));
    while(~scanf("%d%d",&n,&m))
    {
      printf("%d\n",solver(m)-solver(n-1));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值