HDU 4821String(字符串hash)

String

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 3
Font: Times New Roman | Verdana | Georgia
Font Size:  

Problem Description

Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.

Input

The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.

Output

For each test case, output the answer in a single line.

Sample Input

3 3
abcabcbcaabc

Sample Output

2

Source

2013 Asia Regional Changchun
想法:字符串hash+map去重
代码:
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<map>
#define N 100005
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e5+10;
const int seed = 31;
char s[maxn];
int m,l;
int next[maxn];
ull h[maxn];
ull base[maxn];
map<ull, int> mp;
ull string_hash(int l, int r)
{
    return h[r] - h[l-1]*base[r-l+1];//熟练掌握字符串哈希的写法,有点类似前缀和的思想;
}
int main()
{
    base[0] = 1;
    for(int i = 1; i < maxn; i++)
        base[i] = base[i-1]*seed;//每一位的权重;
    while(~scanf("%d%d",&m,&l))
    {
        scanf("%s",s+1);
        int len = strlen(s+1);
        h[0] = 0;
        for(int i = 1; i <= len; i++)
        h[i] = h[i-1]*seed + s[i] - 'a';//对整个字符串进行哈希;
        int ans = 0;
        for(int i = 1; i <= l&&i + m*l<= len; i++)//注意循环条件的判断
        {
            mp.clear();
            for(int j = i; j < i + m*l ; j+=l)
            {
                ull x = string_hash(j,j+l-1);
                //printf("%lld ",x);
                mp[x]++;
            }
            //printf("\n");
            if(mp.size() == m) ans++;//mp自带去重,好用啊!
            //printf("%d %d\n",i,ans);
            for(int j = i + m*l; j + l-1 <= len; j += l)//细细体会。。。。去头添尾;
            {
                ull x = string_hash(j,j+l-1);
                mp[x]++;
                ull y = string_hash(j-m*l,j-m*l+l-1);
                mp[y]--;
                if(mp[y] == 0) mp.erase(y);
                if(mp.size() == m) ans++;
            }
         }
         printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值