FZU-2150---Fire Game (双向bfs)

Problem 2150 Fire Game

Accept: 2690    Submit: 9220
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

43 3.#.###.#.3 3.#.#.#.#.3 3...#.#...3 3###..##.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意:给一个图,#代表草地,选两个火源,火可以同时向上下左右四个方向蔓延,问最少多少时间能把操烧光,若不能输出-1;
思路:数据范围很小,枚举每两个草地作为火源,然后双向fbs,也就是两个火源同时开始蔓延,知道结束;
AC代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<stack>
#define inf 0x7fffffff
using namespace std;
int n,m;
int sum;
char a[15][15];
struct node
{
    int x;
    int y;
    int step;
}arr[105],tmp,q;
queue<node> que;
int vis[15][15];//标记数组
int next[4][2]={1,0,-1,0,0,1,0,-1};//方向数组

bool check(int x,int y)//判断当前点是否符和要求
{
    if(x<1||x>n||y<1||y>m) return false;
    if(vis[x][y]||a[x][y]!='#')  return false;
    return true;
}

int bfs(int u,int v)
{
    while(que.size()) que.pop();
    memset(vis,0,sizeof(vis));
    q.x=arr[u].x;q.y=arr[u].y;q.step=0;//将两个火源入队
    que.push(q);
    q.x=arr[v].x;q.y=arr[v].y;q.step=0;
    que.push(q);
    vis[arr[u].x][arr[u].y]=1;//标记,烧过了就不在烧第二遍
    vis[arr[v].x][arr[v].y]=1;
    int cnt=v==u?1:2;
    while(que.size())
    {
        tmp=que.front();
        que.pop();
        for(int i=0;i<4;i++)
        {
            int tx=tmp.x+next[i][0];
            int ty=tmp.y+next[i][1];
            if(check(tx,ty))
            {
                q.x=tx;
                q.y=ty;
                q.step=tmp.step+1;
                vis[tx][ty]=1;
                que.push(q);
                cnt++;
                if(cnt==sum) return q.step;
            }
        }
    }
    return -1;
}
int main()
{
    int t;
    int cas=0;
    cin>>t;
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
            scanf("%s",a[i]+1);
        int cnt=0;
        sum=0;
        for(int i=1;i<=n;i++){
            for(int j=1;j<=m;j++){
                if(a[i][j]=='#')
                    sum++,arr[++cnt].x=i,arr[cnt].y=j;
            }
        }
        printf("Case %d: ",++cas);
        if(sum<=2)
        {
            printf("0\n");
            continue;
        }
        int ans=inf;
        for(int i=1;i<=cnt;i++){
            for(int j=i;j<=cnt;j++){
                if(bfs(i,j)!=-1) ans=min(ans,bfs(i,j));
            }
        }
        if(ans==inf)
            printf("-1\n");
        else
            printf("%d\n",ans);
    }
    return 0;
}



评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值