FZU-2150-Fire Game

 Fire Game

Accept: 1491    Submit: 5330
Time Limit: 1000 mSec    Memory Limit : 32768 KB

Problem Description

Fat brother and Maze are playing a kind of special (hentai) game on an N*M board (N rows, M columns). At the beginning, each grid of this board is consisting of grass or just empty and then they start to fire all the grass. Firstly they choose two grids which are consisting of grass and set fire. As we all know, the fire can spread among the grass. If the grid (x, y) is firing at time t, the grid which is adjacent to this grid will fire at time t+1 which refers to the grid (x+1, y), (x-1, y), (x, y+1), (x, y-1). This process ends when no new grid get fire. If then all the grid which are consisting of grass is get fired, Fat brother and Maze will stand in the middle of the grid and playing a MORE special (hentai) game. (Maybe it’s the OOXX game which decrypted in the last problem, who knows.)

You can assume that the grass in the board would never burn out and the empty grid would never get fire.

Note that the two grids they choose can be the same.

Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each case contains two integers N and M indicate the size of the board. Then goes N line, each line with M character shows the board. “#” Indicates the grass. You can assume that there is at least one grid which is consisting of grass in the board.

1 <= T <=100, 1 <= n <=10, 1 <= m <=10

Output

For each case, output the case number first, if they can play the MORE special (hentai) game (fire all the grass), output the minimal time they need to wait after they set fire, otherwise just output -1. See the sample input and output for more details.

Sample Input

4
3 3
.#.
###
.#.
3 3
.#.
#.#
.#.
3 3
...
#.#
...
3 3
###
..#
#.#

Sample Output

Case 1: 1
Case 2: -1
Case 3: 0
Case 4: 2

题意:
给定一个大小为 n*m 的区域,'#' 表示草地,'.'表示空地,现在要在两个地方放火,火每单位时间只能向上下左右四个方向扩散,并且只能在草上面烧,求烧完所有区域的最短时间,无解输出 -1。

题目链接:Fire Game

解题思路:
注意到题目的数据n,m <= 10,所以枚举所有对可行的草地坐标,进行BFS,关键是掌握BFS的一般写法(太久没做了,DFS接触得比较多),然后暴力求出最值即可,注意草地数目< 2时的情况。


代码:
#include<cstdio>
#include<iostream>
#include<map>
#include<cmath>
#include<cstring>
#include<vector>
#include<queue>
#include<string>
#include<algorithm>
#define si(x) scanf("%d",&x);
#define sii(x,y) scanf("%d%d",&x,&y);
#define siii(x,y,z) scanf("%d%d%d",&x,&y,&z);
#define rep(i,s,n) for(i = s;i <= n;i++)
#define dow(i,n,s) for(i = n;i >= s;i--)

using namespace std;

char s[15][15];
int n,m,vis[15][15];
int dx[4] = {1,0,-1,0},dy[4] = {0,1,0,-1};  //四个方向

struct node
{
    int y,x,cnt;
};
vector< node > vex;
queue< node > qe;

bool board(int y,int x)
{
    if(y < 0 || y >= n || x < 0 || x >= m)
        return false;
    return true;
}

void Handle()
{
    vex.clear();
    int i,j;
    rep(i,0,n - 1) {
        rep(j,0,m - 1) {
            if(s[i][j] == '#') {
                node p;
                p.y = i, p.x = j, p.cnt = 0;
                vex.push_back( p );
            }
        }
    }
}

int bfs(int a,int b)
{
    memset(vis,0,sizeof (vis) );
    vis[ vex[a].y ][ vex[a].x ] = 1;
    vis[ vex[b].y ][ vex[b].x ] = 1;
    int ans = -1,i;
    while( !qe.empty() ) {      //BFS非递归算法
        node p = qe.front();
        qe.pop();
        ans = max(ans,p.cnt);
        rep(i,0,3) {
            int y = p.y + dy[i], x = p.x  + dx[i];  //从改点开始向四周扩散

            if( !vis[ y ][ x ] && board(y,x) && s[y][x] == '#') {
                node q;
                q.y = y, q.x = x, q.cnt = p.cnt + 1;

                qe.push( q );
                vis[ y ][ x ] = 1;
            }
        }
    }
    return ans;
}

bool rest()         //判断此时是否还有没有烧完的草地
{
    int i;
    rep(i,0,vex.size() - 1) {
        if(!vis[ vex[i].y ][ vex[i].x ])
            return true;
    }
    return false;
}
int main()
{
    int T,i,j,ans,cas = 1;
    si(T);
    while(T--) {
        sii(n,m);
        rep(i,0,n - 1) {
            scanf("%s",s[i]);
        }
        Handle();       //将所有草地的位置存入vex数组里

        if(vex.size() <= 1) ans = 0;    //没有草或者只有一块草时
        else                ans = 9999;
        rep(i,0,vex.size() - 1) {
            rep(j,i + 1,vex.size() - 1) {
                qe.push( vex[i] ),qe.push( vex[j] );

                int mn = bfs(i,j);  //从第 i 和 j 两块草地开始烧
                if(mn == -1 || rest() ) continue;   //无解,或者烧完后还有剩余的草地
                ans = min(mn,ans);
            }
        }
        printf("Case %d: %d\n",cas++,ans == 9999? -1 : ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值