HDU1875畅通工程再续——kruskal模板套用

Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.

Sample Input
2
2
10 10
20 20
3
1 1
2 2
1000 1000

Sample Output
1414.2
oh!

#include<stdio.h>
#include<algorithm>
#include<math.h>
#define MAX 101
using namespace std;
int c;//小岛的个数 
struct island
{
	double x,y;
}land[MAX];
struct Edge
{
	int from,to;
	double dis;
}e[10001];
int cnt;//小岛之间路的个数
int a[MAX];
int father(int x)
{
	if(a[x]==x)
		return x;
	a[x]=father(a[x]);
	return father(a[x]);
}
void merge(int x,int y)
{
	if(father(x)!=father(y))
		a[father(x)]=father(y);
}
double kruskal()
{
	int tag=0;
	double sum=0;
	for(int i=0;i<cnt;i++)
	{
		if(father(e[i].from)!=father(e[i].to)&&10<=e[i].dis&&e[i].dis<=1000)
		{
			merge(e[i].from,e[i].to);
			sum+=e[i].dis;
			tag++;
		}
		if(tag==c-1)
			return sum;
	}
	if(tag<c-1)
		return -1;
}
bool cmp(Edge x,Edge y)
{
	return x.dis<y.dis;
}
int main()
{
	int t;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&c);
			for(int i=0;i<c;i++)
				scanf("%lf %lf",&land[i].x,&land[i].y);
			cnt=0;
			double x1,x2,y1,y2;
			for(int i=0;i<c;i++)
				for(int j=0;j<c;j++)
					if(i!=j)
					{
						e[cnt].from=i;e[cnt].to=j;
						x1=land[i].x;x2=land[j].x;
						y1=land[i].y;y2=land[j].y;
						e[cnt].dis=sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
						cnt++;
					}
			sort(e,e+cnt,cmp);
			for(int i=0;i<c;i++)
				a[i]=i;
			double temp=kruskal();
			if(temp==-1)
				printf("oh!\n");
			else printf("%.1lf\n",temp*100);
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值