3342数据结构实验之二叉树三:统计叶子数

数据结构实验之二叉树三:统计叶子数


Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Example Input


abc,,de,g,,f,,,

Example Output


3

解题感触
调试这道题花费了很长时间,程序运行错误。主要原因是输入数据有多组,i没有置零,另外,程序终止原因待定。。。。。


代码

#include <stdio.h>
#include <stdlib.h>
char str[51];
int i;
typedef struct BiNode{
    char data;
    struct BiNode *lchild,*rchild;
}BiNode,*BiTree;
BiTree creatBiTree(BiTree T)
{
    char temp=str[i++];
    if(temp==',')
        T=NULL;
    else{
        T=(BiTree)malloc(sizeof(BiNode));
        T->data=temp;
        T->lchild=creatBiTree(T->lchild);
        T->rchild=creatBiTree(T->rchild);
    }
    return T;
}
int LeaveCount(BiTree T)
{
    if(T==NULL)
        return 0;
   if(T->lchild==NULL&&T->rchild==NULL)
   {
       return 1;
   }else
        return LeaveCount(T->lchild)+LeaveCount(T->rchild);
}
int main()
{
    while(~scanf("%s",str))
    {
        i=0;//修改处
        BiTree T;
        T=creatBiTree(T);
        printf("%d\n",LeaveCount(T));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值