Prime Ring Problem

A ring is compose of n circles as shown in diagram. Put natural number
1, 2, …, n into each circle separately, and the sum of numbers in
two adjacent circles should be a prime.

Note: the number of first circle should always be 1.
这里写图片描述

Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a
series of circle numbers in the ring beginning from 1 clockwisely and
anticlockwisely. The order of numbers must satisfy the above
requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8

Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

解题思路:

示例:6
其实整道题的算法思想就是回溯。


代码:

#include<math.h>
#include<iostream>
#include<cstring>
using namespace std;
int n,q[21],visited[21];
bool isPrime(int t)
{
    int i;
    if(t==2)
        return true;
    for(i=2;i<t;i++)
    {
        if(t%i==0)
            return false;
    }
    return true;
}
/*深搜有一种不撞南墙不回头的感觉,只要不到头就会一直往下走
当走到头后,函数执行结束,进行回溯,因为我们要得到所有的结果,所以再把*/
void DFS(int step)//用q[]来存储找到的顶点,t代表数组下标,该找第t+1个顶点了
{
    if(step==n&&isPrime(q[n-1]+1))//找到满足条件的就打印出来
    {
        for(int i=0;i<n;i++)
        {
            if(i==n-1)
                cout<<q[i]<<endl;
            else
                cout<<q[i]<<" ";
        }

    }
    else{
        for(int i=2;i<=n;i++)
        {
            if(!visited[i]&&isPrime(i+q[step-1]))
            {
                visited[i]=1;
                q[step]=i;
                DFS(step+1);//递归寻找
                visited[i]=0;//回溯
            }
        }

    }

}


int main()
{
    int cnt=0;
    while(cin>>n)
    {
        memset(visited,0,sizeof(visited));
        cnt++;
        q[0]=1;
        cout<<"Case "<<cnt<<":"<<endl;
        DFS(1);
        cout<<endl;
    }
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值