2017年ACM第八届山东省赛F题:quadratic equation(离散数学蕴含式)- SDUT3898

Problem Description

With given integers a,b,c, you are asked to judge whether the following statement is true: "For any x, if a+bx+c=0, then x is an integer."

Input

The first line contains only one integer T(1≤T≤2000), which indicates the number of test cases.
For each test case, there is only one line containing three integers a,b,c(−5≤a,b,c≤5).

Output

or each test case, output “YES” if the statement is true, or “NO” if not.

Sample Input
3
1 4 4
0 0 1
1 3 1
Sample Output
YES
YES
NO
Hint
Source
“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)

解题感悟:这道题用到了离散数学中的知识,也就是蕴含式,前真后假为假,其余都是真。

#include<iostream>
#include<cmath>
using namespace std;
int main()
{
    int t,a,b,c,tmp;
    cin>>t;
    while(t--){
        cin>>a>>b>>c;
        tmp=b*b-4*a*c;
        if(a==0){
            if(b==0)
                if(c==0)  //解可以取任意值,显然不满足条件
                    cout<<"NO"<<endl;
                else
                    cout<<"YES"<<endl;  //前件不成立
            else{
                if(c%b==0)  //解为整数
                    cout<<"YES"<<endl;
                else  //解不是整数
                    cout<<"NO"<<endl;
            }
        }else if(tmp<0)  //无解
            cout<<"YES"<<endl;
        else{
            double res=sqrt(1.0*tmp);
            if((-b+res)/(2*a)-(int)((-b+res)/(2*a))==0&&(-b-res)/(2*a)-(int)((-b-res)/(2*a))==0)  //两个解都是整数
                cout<<"YES"<<endl;
            else
                cout<<"NO"<<endl;
        }

    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值