(KMP裸题)hdu1711 Number Sequence

 

Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.

 

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

 

Sample Input

 

213 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 1 313 51 2 1 2 3 1 2 3 1 3 2 1 21 2 3 2 1

 

 

Sample Output

 

6-1

 

 

Source

HDU 2007-Spring Programming Contest

 

 

Recommend

lcy   |   We have carefully selected several similar problems for you:  1358 3336 3746 1251 2222 

 

#include<iostream>
using namespace std;
const int maxn=1e6+10;
int n,m;
int a[maxn],mo[maxn],nxt[maxn];

void getNext()
{
    int i=0,j=-1;
    nxt[0]=-1;
    while(i<m){
        if(j==-1||mo[i]==mo[j])
            nxt[++i]=++j;
        else
            j=nxt[j];
    }
}

int KMP()
{
    getNext();
    int i=0,j=0;
    int ans=-1;
    while(i<n){
        if(j==-1||a[i]==mo[j])
            ++i,++j;
        else
            j=nxt[j];
        if(j==m)
            return i-m+1;
    }
    return ans;
}

int main()
{
    std::ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    cin>>t;
    while(t--){
        cin>>n>>m;
        for(int i=0;i<n;i++)
            cin>>a[i];
        for(int i=0;i<m;i++)
            cin>>mo[i];
        cout<<KMP()<<endl;
    }

    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值