待补.....(KMP循环节)hdu1358 Period

hdu1358 Period

 

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

 

 

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

 

 

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

 

 

Sample Input

 

3aaa12aabaabaabaab0

 

 

Sample Output

 

Test case #12 23 3Test case #22 26 29 312 4

本题主要是理解KMP中nxt[]的含义,现在状态不好,明天不上题解  循环节这块短期内突破不了了,待我下周有时间啦,慢慢突破吧,,,,,

next 数组的应用 --- 前缀中最小循环节,最大重复次数

kmp总结及其应用

#include<iostream>
#include<string>
#include<string.h>
#include<cstdio>
using namespace std;
const int maxn=1e6+10;
int n,nxt[maxn];
char str[maxn];

void getNext()
{
    int i=0,j=-1;
    nxt[0]=-1;
    while(i<n){
        if(j==-1||str[i]==str[j])
            nxt[++i]=++j;
        else
            j=nxt[j];
    }
}

void getRes(int ncase)
{
    getNext();
    printf("Test case #%d\n",ncase);
    for(int i=0;i<=n;i++)
    {
        if(nxt[i]>0){
            int j=i-nxt[i];
            if(i%j==0)
                printf("%d %d\n",i,i/j);
        }
    }
    printf("\n");
}

int main()
{
    int cnt=0;
    while(~scanf("%d",&n)){
        if(n==0)
            break;
        scanf("%s",str);
        getRes(++cnt);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值