Stall Reservations(贪心,****思路理顺)

Stall Reservations

Oh those picky N (1 <= N <= 50,000) cows! They are so picky that each one will only be milked over some precise time interval A..B (1 <= A <= B <= 1,000,000), which includes both times A and B. Obviously, FJ must create a reservation system to determine which stall each cow can be assigned for her milking time. Of course, no cow will share such a private moment with other cows.

Help FJ by determining:
The minimum number of stalls required in the barn so that each cow can have her private milking period
An assignment of cows to these stalls over time
Many answers are correct for each test dataset; a program will grade your answer.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 describes cow i’s milking interval with two space-separated integers.

Output

Line 1: The minimum number of stalls the barn must have.

Lines 2..N+1: Line i+1 describes the stall to which cow i will be assigned for her milking period.
Sample Input
5
1 10
2 4
3 6
5 8
4 7

Sample Output

4
1
2
3
2
4

Hint

Explanation of the sample:

Here’s a graphical schedule for this output:

Time 1 2 3 4 5 6 7 8 9 10
Stall 1 c1>>>>>>>>>>>>>>>>>>>>>>>>>>>

Stall 2 .. c2>>>>>> c4>>>>>>>>> .. ..

Stall 3 .. .. c3>>>>>>>>> .. .. .. ..

Stall 4 .. .. .. c5>>>>>>>>> .. .. ..
Other outputs using the same number of stalls are possible.

题意:

有n头奶牛,每头奶牛喝牛奶的时候都不愿意被打扰,告诉你每头奶牛开始喝牛奶和结束和牛奶的时间 a 和 b, 求至少需要多少个隔间,使每头奶牛喝牛奶的时间不相交

输入:

第一行 n
接下来n行,第n-1头奶牛的时间 a b

输出:

第一行:最小的隔间数
接下来n行:每头奶牛对应的隔间标号(只输出一种情况即可)

思路:

每头奶牛按照开始的时间从小到大排,每一次如果能安排进最早结束的隔间,则刷新此隔间的结束时间,否则开一个新的隔间
奶牛用结构体存储开始,结束时间和隔间号

注意

代码的结构和时间要求

#include <iostream>
#include <cstring>
#include <map>
#include <cstdio>
#include <queue>
#include <algorithm>
using namespace std;
struct cow
{
    int s,e,num,id;
    cow(int s=0,int e=0,int num=0):s(s),e(e),num(num) {};
};
bool cmp (const cow& a,const cow& b){
    return a.num<b.num;
}
bool operator < (const cow& a,const cow &b){
    return a.s<b.s;
}
cow c[55000];
typedef pair<int,int> Pir;

int main()
{
    //freopen("1.txt","r",stdin);
    int n;
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++){
            int a,b; scanf("%d%d",&a,&b);
            c[i]=cow(a,b,i+1);    //初始化n头奶牛
        }
        sort(c,c+n);
        int room=0;
        priority_queue<Pir,vector<Pir>,greater<Pir> > que; //每次取结束时间,即.first最小的隔间
        que.push(Pir(c[0].e,++room));
        c[0].id=room;
        for(int i=1;i<n;i++)
        {
                Pir p=que.top();
                if(p.first<c[i].s){ //如果此时开始时间最早的奶牛能安排进结束时间最早的隔间
                    que.pop();
                    que.push(Pir(c[i].e,p.second));
                    c[i].id=p.second; //记录排进的隔间编号
                }   else{           //如果不能
                    que.push(Pir(c[i].e,++room));
                    c[i].id=room;
                }
        }

        cout<<room<<endl;
        sort(c,c+n,cmp);   //按输入顺序重新排序,便于输出
        for(int i=0;i<n;i++)
            printf("%d\n",c[i].id);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值