HDU 4035 maze 概率期望dp

Problem Description
When wake up, lxhgww find himself in a huge maze.

The maze consisted by N rooms and tunnels connecting these rooms. Each pair of rooms is connected by one and only one path. Initially, lxhgww is in room 1. Each room has a dangerous trap. When lxhgww step into a room, he has a possibility to be killed and restart from room 1. Every room also has a hidden exit. Each time lxhgww comes to a room, he has chance to find the exit and escape from this maze.

Unfortunately, lxhgww has no idea about the structure of the whole maze. Therefore, he just chooses a tunnel randomly each time. When he is in a room, he has the same possibility to choose any tunnel connecting that room (including the tunnel he used to come to that room).
What is the expect number of tunnels he go through before he find the exit?

Input
First line is an integer T (T ≤ 30), the number of test cases.

At the beginning of each case is an integer N (2 ≤ N ≤ 10000), indicates the number of rooms in this case.

Then N-1 pairs of integers X, Y (1 ≤ X, Y ≤ N, X ≠ Y) are given, indicate there is a tunnel between room X and room Y.

Finally, N pairs of integers Ki and Ei (0 ≤ Ki, Ei ≤ 100, Ki + Ei ≤ 100, K1 = E1 = 0) are given, indicate the percent of the possibility of been killed and exit in the ith room.

Output
For each test case, output one line “Case k: ”. k is the case id, then the expect number of tunnels lxhgww go through before he exit. The answer with relative error less than 0.0001 will get accepted. If it is not possible to escape from the maze, output “impossible”.

Sample Input
3
3
1 2
1 3
0 0
100 0
0 100
3
1 2
2 3
0 0
100 0
0 100
6
1 2
2 3
1 4
4 5
4 6
0 0
20 30
40 30
50 50
70 10
20 60

Sample Output
Case 1: 2.000000
Case 2: impossible
Case 3: 2.895522

分析:我只是想水水概率期望,因为目测要考,结果这道题手算量实在大。说正解,我们要求总的道路,不难看出是求期望,于是从后往前,若是叶子节点:E[i] = ki**E[1]* + ei*0* + (1-ki-ei)*(E[father[i]] + 1);
= ki*E[1] + (1-ki-ei)*E[father[i]] + (1-ki-ei);
非叶子结点:(m为与结点相连的边数)
E[i] = ki* E[1] + *ei*0 +* (1-ki-ei)/m*( E[father[i]]+1 + ∑( E[child[i]]+1 ) );
= ki* E[1] + (1 - ki-ei)/mE[father[i]] + (1-ki-ei)/m*∑(E[child[i]]) + (1-ki-ei);
额,我能说显然吗?自己推推就搞定了,然后定义:
∑(E[child[i]]) = ∑E[j]
= ∑(Aj* E[1]* + Bj*E[father[j]] + Cj)
= ∑(Aj* E[1]* + Bj*E[i] + Cj)
带入上面的式子得
(1 - (1-ki-ei)/m**∑Bj)E[i] = (ki+(1-ki-ei)/m∑Aj)E[1] + (1-ki-ei)/m**E[father[i]] + (1-ki-ei) + (1-ki-ei)/m∑Cj;
由此可得
Ai = (ki+(1-ki-ei)/m*∑Aj) / (1 - (1-ki-ei)/m*∑Bj);
Bi = (1-ki-ei)/m / (1 - (1-ki-ei)/m*∑Bj);
Ci = ( (1-ki-ei)+(1-ki-ei)/m*∑Cj ) / (1 - (1-ki-ei)/m*∑Bj);

最后手算一下不难看出,e[1]=c[1]/(1-a[1]);多动手有益身心健康,前往不要偷懒,想想算圆锥曲线。
这里有篇dalao博客,写得不能再详细了,我蒟蒻说不清,看不懂的去dalao博客逛逛吧:(http://www.cnblogs.com/kuangbin/archive/2012/10/03/2711108.html)

# include <iostream>
# include <cstdio>
# include <cmath>
# include <list>
# include <cstring>
# include <map>
# include <ctime>
# include <algorithm>
# include <queue>
using namespace std;
typedef long long ll;
int read(){
    int f=1,i=0;char ch=getchar();
    while(ch<'0'||ch>'9') {if(ch=='-') f=-1;ch=getchar();}
    while(ch>='0'&&ch<='9') {i=(i<<3)+(i<<1)+ch-'0';ch=getchar();}
    return f*i;
}
const double eps=1e-10;
const int N=10005;
double a[N],b[N],c[N],k[N],e[N],p[N];
int x,y,n,m,z,t,ctr;
vector<int >q[N];
bool DFS(int u,int fa)
{
    int size=q[u].size();
    a[u]=k[u];
    b[u]=p[u]/size;
    c[u]=p[u];
    double tmp=0;
    for(int i=0;i<size;++i)
    {
        int v=q[u][i];
        if(v==fa) continue;
        if(!DFS(v,u)) return 0;
        a[u]+=p[u]/size*a[v];
        c[u]+=p[u]/size*c[v];
        tmp+=p[u]/size*b[v];
    }
    if(fabs(tmp-1)<eps) return 0;
    a[u]/=(1-tmp);
    b[u]/=(1-tmp);
    c[u]/=(1-tmp);
    return 1;
}
int main()
{
    freopen("lx.in","r",stdin);
    t=read();
    while(t--)
    {
        n=read();ctr++;
        for(int i=1;i<=n;i++)q[i].clear();
        for(int i=1;i<n;++i)
        {
            x=read(),y=read();
            q[x].push_back(y);
            q[y].push_back(x);
        }
        for(int i=1;i<=n;++i)
        {
            scanf("%lf%lf",&k[i],&e[i]);
            k[i]/=100,e[i]/=100;
            p[i]=1-k[i]-e[i];
        }
        printf("Case %d: ",ctr);
        if(DFS(1,-1)&&fabs(a[1]-1)>eps)
            printf("%0.6f\n",c[1]/(1-a[1]));
        else puts("impossible");
    }
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值