hdu 4035 Maze

108 篇文章 0 订阅
Maze
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 1256    Accepted Submission(s): 458
Special Judge


Problem Description
When wake up, lxhgww find himself in a huge maze.


The maze consisted by N rooms and tunnels connecting these rooms. Each pair of rooms is connected by one and only one path. Initially, lxhgww is in room 1. Each room has a dangerous trap. When lxhgww step into a room, he has a possibility to be killed and restart from room 1. Every room also has a hidden exit. Each time lxhgww comes to a room, he has chance to find the exit and escape from this maze.


Unfortunately, lxhgww has no idea about the structure of the whole maze. Therefore, he just chooses a tunnel randomly each time. When he is in a room, he has the same possibility to choose any tunnel connecting that room (including the tunnel he used to come to that room).
What is the expect number of tunnels he go through before he find the exit?


 


Input
First line is an integer T (T ≤ 30), the number of test cases.


At the beginning of each case is an integer N (2 ≤ N ≤ 10000), indicates the number of rooms in this case.


Then N-1 pairs of integers X, Y (1 ≤ X, Y ≤ N, X ≠ Y) are given, indicate there is a tunnel between room X and room Y.


Finally, N pairs of integers Ki and Ei (0 ≤ Ki, Ei ≤ 100, Ki + Ei ≤ 100, K1 = E1 = 0) are given, indicate the percent of the possibility of been killed and exit in the ith room.


 


Output
For each test case, output one line “Case k: ”. k is the case id, then the expect number of tunnels lxhgww go through before he exit. The answer with relative error less than 0.0001 will get accepted. If it is not possible to escape from the maze, output “impossible”.


 


Sample Input
3
3
1 2
1 3
0 0
100 0
0 100
3
1 2
2 3
0 0
100 0
0 100
6
1 2
2 3
1 4
4 5
4 6
0 0
20 30
40 30
50 50
70 10
20 60
 


Sample Output
Case 1: 2.000000
Case 2: impossible

Case 3: 2.895522

  设 E[i]表示在结点i处,要走出迷宫所要走的边数的期望。E[1]即为所求。

    叶子结点:
    E[i] = ki*E[1] + ei*0 + (1-ki-ei)*(E[father[i]] + 1);
         = ki*E[1] + (1-ki-ei)*E[father[i]] + (1-ki-ei);

    非叶子结点:(m为与结点相连的边数)
    E[i] = ki*E[1] + ei*0 + (1-ki-ei)/m*( E[father[i]]+1 + ∑( E[child[i]]+1 ) );
         = ki*E[1] + (1-ki-ei)/m*E[father[i]] + (1-ki-ei)/m*∑(E[child[i]]) + (1-ki-ei);

    设对每个结点:E[i] = Ai*E[1] + Bi*E[father[i]] + Ci;

    对于非叶子结点i,设j为i的孩子结点,则
    ∑(E[child[i]]) = ∑E[j]
                   = ∑(Aj*E[1] + Bj*E[father[j]] + Cj)
                   = ∑(Aj*E[1] + Bj*E[i] + Cj)
    带入上面的式子得
    (1 - (1-ki-ei)/m*∑Bj)*E[i] = (ki+(1-ki-ei)/m*∑Aj)*E[1] + (1-ki-ei)/m*E[father[i]] + (1-ki-ei) + (1-ki-ei)/m*∑Cj;
    由此可得
    Ai =        (ki+(1-ki-ei)/m*∑Aj)   / (1 - (1-ki-ei)/m*∑Bj);
    Bi =        (1-ki-ei)/m            / (1 - (1-ki-ei)/m*∑Bj);
    Ci = ( (1-ki-ei)+(1-ki-ei)/m*∑Cj ) / (1 - (1-ki-ei)/m*∑Bj);

    对于叶子结点
    Ai = ki;
    Bi = 1 - ki - ei;
    Ci = 1 - ki - ei;

    从叶子结点开始,直到算出 A1,B1,C1;

    E[1] = A1*E[1] + B1*0 + C1;
    所以
    E[1] = C1 / (1 - A1);
    若 A1趋近于1则无解...

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <vector>
using namespace std;
#define eps 1e-9
#define M 100500
double a[M],b[M],c[M],x[M],k[M],p[M],m[M],e[M];
vector<int > vec[M];
int dfs(int now,int pre){
    m[now]=vec[now].size();
    if(vec[now].size()==1){
        a[now]=k[now];b[now]=1-k[now]-e[now];c[now]=1-k[now]-e[now];
        //return 1;
    }
    x[now]=(1-k[now]-e[now])/m[now];
    double tempb=0,tempa=0,tempc=0;
    for(int i=0;i<vec[now].size();i++){
        int j=vec[now][i];
        if(j==pre)continue;
        if(!dfs(j,now))return false;
        tempa+=a[j],tempb+=b[j],tempc+=c[j];
    }
    double tmpk=(1-x[now]*tempb);
    if(fabs(tmpk)<eps)return 0;
    a[now]=(k[now]+x[now]*tempa)/tmpk;
    b[now]=x[now]/tmpk;
    c[now]=(1-k[now]-e[now]+x[now]*tempc)/tmpk;
    return 1;
}
int main()
{
    int tcase,i,ss,ee,tt=1,n;
    scanf("%d",&tcase);
    while(tcase--){
        scanf("%d",&n);
        for(i=0;i<=n;i++)
        vec[i].clear();
        for(i=1;i<n;i++){
            scanf("%d%d",&ss,&ee);
            vec[ee].push_back(ss);
            vec[ss].push_back(ee);
        }
        for(i=1;i<=n;i++){
        scanf("%lf%lf",&k[i],&e[i]);
        k[i]/=100.0;e[i]/=100.0;
        }
        if(dfs(1,-1)&&(1-a[1])>eps){
            printf("Case %d: %.6f\n",tt++,c[1]/(1.0-a[1]));
        }
        else
        printf("Case %d: impossible\n",tt++);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值