(两种解法)hdu 1540 Tunnel Warfare (线段树区间合并)

During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones. 

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately! 
Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event. 

There are three different events described in different format shown below: 

D x: The x-th village was destroyed. 

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself. 

R: The village destroyed last was rebuilt. 
Output
Output the answer to each of the Army commanders’ request in order on a separate line. 
Sample Input
7 9
D 3
D 6
D 5
Q 4
Q 5
R
Q 4
R
Q 4
Sample Output
1
0
2
4

题意:

三种操作:1.d   x 代表破坏 x 点。

    2.r代表修复上一个被破坏的点。

    3.q  x代表查询与 x 相连接的点个数(包括自己)。

有两种方法,一种用线段树,一种用set,第一次做区间合并,写得很丑(第二种方法代码很短)。

方法一:线段树

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stack>
using namespace std;
const int mx = 5e4 + 5;
struct node{
	int l, r;
	int ls, rs, ms; 
}a[4 * mx];
void build(int l, int r, int rt){
	a[rt].l = l;
	a[rt].r = r;
	a[rt].ls = a[rt].rs = a[rt].ms = r - l + 1;
	if(l != r){
		int mid = (l + r) / 2;
		build(l , mid, 2 * rt);
		build(mid + 1, r, 2 * rt +1);
	}
}
void des(int ro, int p, int ju){
		int l = a[ro].l, r = a[ro].r;
	if(l == r){
		if (ju == 1) a[ro].ls = a[ro].rs = a[ro].ms = 1;
		else a[ro].ls = a[ro].rs = a[ro].ms = 0;
		return ;
	}
	int mid = (l + r) / 2;
	if (p <= mid) 
		des(2 * ro, p, ju);
	else  
		 des(2 * ro + 1, p, ju);
	a[ro].ls = a[2 * ro].ls;
	a[ro].rs = a[2 * ro + 1].rs;
	a[ro].ms = max(max(a[2 * ro].ms, a[2 * ro + 1].ms), a[2 * ro].rs + a[2 * ro + 1].ls);
	
	if(a[2 * ro].r - a[2 * ro].l + 1 == a[2 * ro].ls) 
		a[ro].ls += a[2 * ro + 1].ls;
	if(a[2 * ro + 1].r - a[2 * ro + 1].l + 1 == a[2 * ro + 1].rs)
		a[ro].rs +=a[2 * ro].rs;//rs写成r 
	
}
int que(int ro, int p){
	if(a[ro].ms == 0 || a[ro].l == a[ro].r || a[ro].ms == a[ro].r - a[ro].l + 1)
		return a[ro].ms;
	int mid = (a[ro].l + a[ro].r) / 2;//准备替换 
	if(p <= mid){
		if(p >= a[2 * ro].r - a[2 * ro].rs + 1)
			return que(2 * ro , p)+que(2 * ro + 1, mid + 1);
		else return que(2 * ro, p);
	}
	else {
		if(p <= a[2 * ro + 1].l + a[2 * ro + 1].ls - 1)
			return que(2 * ro, mid) + que(2 * ro + 1, p);
		else return que (2 * ro + 1, p);
	}
}
int main(){
	int n, m, x;
	char cmd;
	stack <int> s;
	while(scanf("%d%d",&n,&m) != EOF){
		build(1, n, 1);
		while(m--){
			getchar();
			scanf("%c", &cmd);
			if(cmd == 'D') {
			scanf("%d", &x);
			des(1, x, 0);
			s.push(x);
			}
			else if(cmd == 'R'){
				if(!s.empty()){
				x = s.top();
				s.pop();
				des(1, x, 1);
				}
			}
			else {
				scanf("%d", &x);
				printf("%d\n", que(1, x));
			}
		}
	}
	return 0;
}  

方法二:set

#include<iostream>
#include<cstdio>
#include<stack>
#include<set>
using namespace std;
set<int> st;
stack<int> sk;
int main(){
	int n, m,x;
	char cmd;
	while(scanf("%d%d",&n, &m) != EOF){
		while(!sk.empty()) sk.pop();
		st.clear();
		st.insert(0);
		st.insert(n + 1);
		while(m--){
			
				getchar();
				scanf("%c", &cmd);
				if(cmd == 'D'){
					scanf("%d", &x);
					sk.push(x);
					st.insert(x);
				}
				else if(cmd == 'R'){
					
					if(!sk.empty()){
						x = sk.top();
						sk.pop();
						if(st.count(x) != 0)
						st.erase(x);
					}
				}
				else {
					scanf("%d",&x);
					set<int>::iterator l, r;
					if(st.count(x) != 0) puts("0");
					else{
						//l = st.lower_bound(x);
						l = r = st.upper_bound(x);
						l --;
						printf("%d\n", *r - *l - 1);  
					}
				}
			}			
		}
	
	
	return 0;
}

深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值