hdu 1150 Machine Schedule(二分匹配,匈牙利算法)

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
InputThe input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 
OutputThe output should be one integer per line, which means the minimal times of restarting machine. 
Sample Input
5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0
Sample Output
3

题意:

两种机器分别有不同的工作模式,每一项任务都可以用两种机器中的一种来完成, 比如(0, 1 , 2)表示第0个任务可以由A机器的 1 模式,或者由B机器的 2 模式来完成, 每次机器切换模式都需要重启, 问最少重启几次可以完成所有的任务。

思路:

第一次接触二分匹配, 套用了模板, 用邻接矩阵记录了两台机器的任务关系。

最小覆盖点数=最大匹配数


#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int mx = 110;
int ma[mx][mx], vis[mx], match[mx];
int n, m , k;
bool dfs(int u){
	for(int v = 1; v <= m; v++){
		if(ma[u][v] && !vis[v]){
			vis[v] = 1;
			if(match[v] == -1 || dfs(match[v])){
				match[v] = u;
				return 1;
			}
		}
	}
	return 0;
}
int main(){

	while(scanf("%d", &n) && n){
		scanf("%d%d", &m, &k);
		int a, b, te, cnt =0;
		
		memset(ma, 0, sizeof(ma));
		memset(match, -1, sizeof(match));
		
		while(k--){
			scanf("%d%d%d", &te, &a, &b);
			ma[a][b] = 1;
		}
		for(int i = 1; i <= n; i++){
			memset(vis, 0, sizeof(vis));
			if(dfs(i)) 
				cnt++;
		}
		
		printf("%d\n", cnt);
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Blaze Jack

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值