1046.Shortest Distance-PAT甲级真题

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

输入格式:

Each input file contains one test case. For each case, the first line contains an integer N (in [3,10^​5]), followed by N integer distances D​1​ D​2​ ⋯ D​N​​, here D​i is the distance between the i-th and the (i+1)-st exits, and D​N ​is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤10^​4​​), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 10^​7.

输出格式:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

输入样例:
5 1 2 4 14 9
3
1 3
2 5
4 1
输出样例:
3
10
7
解题思路:

根据给出的样例,我们知道顺时针每条有向边的长度。
假定dist[i]存放1号节点到 i+1号节点的距离,sum存放所有有向边的长度总和;则任给节点a到节点b(a>b)的最短距离为min((dist[a-1]-disr[b-1]), sum - (dist[a-1]-disr[b-1])) 。

#include <cstdio>

const int MAXN = 100005;
int dist[MAXN], D[MAXN];

void swap(int &a, int &b);

int main() {
	int N, sum = 0;
	scanf("%d", &N);
	for(int i = 1; i <= N; i++) {
		scanf("%d", &D[i]);
		sum += D[i];
		dist[i] = sum;
	}
	int M, left, right;
	scanf("%d", &M);
	for(int i = 0; i < M; i++) {
		scanf("%d %d", &left, &right);
		if(left > right) swap(left, right);
		int temp = dist[right - 1] - dist[left - 1];
		printf("%d\n", (temp > (sum-temp) ? (sum - temp) : temp));
	}
	return 0;
}
void swap(int &a, int &b) {
	int temp = a;
	a = b;
	b = temp;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
GCN (Graph Convolutional Network) Shortest-Path-Master 是一种基于图卷积网络的最短路径算法。最短路径问题是图论中的经典问题,对于给定的图和起始点,找到到达目标点的最短路径。 GCN Shortest-Path-Master 通过应用图卷积神经网络的思想来解决最短路径问题。传统的最短路径算法(如Dijkstra算法或贝尔曼-福特算法)在计算过程中不考虑节点的特征信息,只利用图的拓扑结构。而GCN Shortest-Path-Master 利用了节点的特征信息,将节点的邻居节点信息通过图卷积操作进行聚合,得到节点的新特征表示。 GCN Shortest-Path-Master 的核心思想是,通过图卷积层不断更新节点的特征表示,使得节点的特征表示能够包含更多关于最短路径的信息。在每次迭代中,GCN Shortest-Path-Master 将节点的特征与邻居节点的特征进行聚合,得到节点的新特征表示。在网络的最后一层,通过对所有节点进行分类任务,可以得到每个节点到达目标点的最短路径预测。 相比传统的最短路径算法,GCN Shortest-Path-Master 提供了以下优势: 1. GCN Shortest-Path-Master 能够利用节点的特征,从而更好地表达节点之间的相互作用和联系。 2. GCN Shortest-Path-Master 可以自适应地学习节点的特征表示,而无需人工定义特征。 3. GCN Shortest-Path-Master 可以处理大规模的图结构,在计算效率上具有一定优势。 总之,GCN Shortest-Path-Master 是一种基于图卷积神经网络的最短路径算法,通过利用节点的特征信息,能够更好地解决最短路径问题。它在图结构数据中的应用具有很大潜力,在社交网络分析、推荐系统和物流路径规划等领域都有广泛的应用前景。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值