1025.PAT Ranking-PAT甲级真题

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

输入格式:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

输出格式:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

输入样例:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
输出样例:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
解题思路:

读懂题意即可。根据题意,定义一个结构体存储每一个考生的注册号、考场号、分数、考场内排名;总排名输出时确定。
排序方式:排名升序,同一分数名次相同,按注册号字典序升序。
特别注意:考场内排序时的起始地址和结束地址。

#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;

struct individual_rank {
	char id[15]; 
	int location_num;
	int score;
	int local_rank;
}ir[30010];

bool cmp(individual_rank a, individual_rank b) {
	if(a.score != b.score) return a.score > b.score;
	else return strcmp(a.id, b.id) < 0;
}

int main() {
	int N, K, num = 0;
	scanf("%d", &N);
	for(int i = 1; i <= N; i++) {
		scanf("%d", &K);
		for(int j = 0; j < K; j++) {
			scanf("%s %d", ir[num].id, &ir[num].score);
			ir[num].location_num = i;
			num++;
		}
		sort(ir + num - K, ir + num, cmp);
		ir[num - K].local_rank = 1;
		for(int j = num - K + 1; j < num; j++) {
			if(ir[j].score != ir[j - 1].score) ir[j].local_rank = j + 1 - num + K;
			else ir[j].local_rank = ir[j - 1].local_rank;
		}
	}
	printf("%d\n", num);
	sort(ir, ir + num, cmp);
	int final_rank = 1;
	for(int i = 0; i < num; i++){
		if(i > 0 && ir[i].score != ir[i - 1].score) final_rank = i + 1;
		printf("%s ", ir[i].id);
		printf("%d %d %d\n", final_rank, ir[i].location_num, ir[i].local_rank);
	}
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值