Can you solve this equation?【二分】+【精度】

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 19270    Accepted Submission(s): 8487


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
 

Author
Redow
 
思路:  简单的二分 使用,二分的使用条件     必须要是有序数列 ,且数据量越大效果越明显  用的时候 即要弄清楚 这个序列的单调性
 
    代码
#include<stdio.h>
#include<math.h>
double f(double x){
	return 8*pow(x,4)+7*pow(x,3)+2*x*x+3*x+6;
}
int main(){
	int t;scanf("%d",&t);
	while(t--){
		double y;scanf("%lf",&y);
		double a,b,c;
		if(f(0.0)-y>0||f(100.0)-y<0) { //因为单调性为单增 所以边界 (结合图看的话会更清晰)
			printf("No solution!\n");  
			continue ; 
		} 
		a=0.0;b=100.0; 
		while(b-a>1e-10) {//  核心   (第一次写的时候 写成fabs(f(c)-y)>1e-10 其实不用,当精度非常高的时候相邻的几个数字都是可以代替 这个解
			c=(a+b)/2;
			if(f(c)-y>0)   // 根据单调性 会有相反的 结论 
				b=c;
			if(f(c)-y<0)  a=c;  
		}
		printf("%.4lf\n",a); //  这里就有体现,其实输出a,输出b,甚至是输出 c 都不会影响整道题目 (当然这是由于精度已经足够高了,远远高于题目要求才这样)
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值