Frogger【最小生成树的变形】---路径上最小的最大权

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414
 
 
思路    给出一个无向图,求一条1~2的路径使得路径上的最大边权最小.
1-2 的所有连通路径中,都会有一个跳的最远的距离d,现在要求 所有路径中这个d最小的  那个路径
代码
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stack>
#define inf 0x3f3f3f
#define M 1000+10
using namespace std;
double map[M][M];  //  距离是浮点数字 
int v[M];    
double dis[M];   // 距离是浮点数子 
int n;
int ll=1;
typedef struct 
{
	int x,y;
}data;
data a[M];
double minn(double x,double y)
{
	if(x>y) return y;
	else return x;
}
double dist(data a,data b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)*1.0);
}
void djk(int st,int ed)
{
	double min;int next;
	for(int i=1;i<=n;i++)
	{
		v[i]=0;
		dis[i]=map[st][i];
	}
	v[st]=1; dis[st]=0;
	for(int u=2;u<=n;u++)
	{
		min=inf*1.0;
		for(int j=1;j<=n;j++)
		{
			if(!v[j]&&dis[j]<min)
			{
				min=dis[j];
				next=j;
			}
		}
		v[next]=1;// 又忘 
		for(int i=1;i<=n;i++)
		{
			if(!v[i])
			{
				dis[i] = minn(dis[i],max(dis[next],map[next][i]));  // 关键变形  
			}//求的是 从源点到next点然后到 j 点 这是一条路,从源点到 直接到 j  点 也是一条路;
		}	// 先找到每条路中的d的最大值,然后再找出 这两个d的最小值
	}
	printf("Scenario #%d\nFrog Distance = %.3f\n\n",ll++,dis[ed]);
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		for(int i=1;i<=n;i++)
		scanf("%d%d",&a[i].x,&a[i].y);
		for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		if(i==j) map[i][j]=0.0;
		else map[i][j]=inf;
				
		for(int i=1;i<=n;i++)  //  可以表示 每两条路之间的距离 
		for(int j=i+1;j<=n;j++)// 造图 
		{
			double d=dist(a[i],a[j]);
			if(map[i][j]>d)
			map[i][j]=map[j][i]=d; 
		}
		djk(1,2); 
	}
	
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值