poj2253 最小生成树最大权

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 32122 Accepted: 10351

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2

Frog Distance = 1.414

A青蛙在第一个坐标,B青蛙在第二个坐标,A要到B青蛙那,可以从任意石头之间跳,问A青蛙最少能跳多远

#include <iostream>
#include <queue>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
struct edge
{
    double x,y;
} d[205];
const double inf=1e9*1.0;
double fd(edge a,edge b)
{
    return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double map[202][202];
int main()
{
    int n;
    int tot=1;
    bool used[205];
    double cost[202];
    while(cin>>n)
    {
        memset(used,false,sizeof(used));
        if(n==0)
            break;
        for(int i=1; i<=n; i++)
            cin>>d[i].x>>d[i].y;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
                map[i][j]=fd(d[i],d[j]);
        }
        used[1]=true;
        double ans=-inf;
        for(int i=1; i<=n; i++)
            cost[i]=map[1][i];///集合cost
        for(int i=1; i<n; i++)///n个点,n-1边
        {
            double minc=inf;
            int k=-1;
            for(int j=1; j<=n; j++)///寻找下一步可以跳的最近的距离
            {
                if(!used[j]&&minc>cost[j])
                {
                    minc=cost[j];
                    k=j;
                }
            }
            ans=max(ans,minc);///最大权
            used[k]=true;
            if(k==2)///找到B
                break;
            for(int j=1; j<=n; j++)///更新cost 从K到j的最小距离
            {
                if(map[k][j]<cost[j]&&!used[j])
                {
                    cost[j]=map[k][j];
                }
            }
        }
        printf("Scenario #%d\n",tot++);
        printf("Frog Distance = %.3f\n\n",ans);
    }
    // cout << "Hello world!" << endl;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Kruskal算法是一种用来求解最小生成树的贪心算法。它的基本思想是,按照边的权值从小到大的顺序选择边,并且保证所选的边不会形成环,直到选取了n-1条边为止。另外,Kruskal算法还需要使用并查集来判断两个节点是否属于同一个连通分量。 在具体的实现过程中,可以按照以下步骤进行: 1. 将图中的所有边按照权值从小到大排序。 2. 创建一个并查集,并初始化每个节点为一个独立的集合。 3. 遍历排序后的边列表,对于每一条边(u, v),判断u和v是否属于同一个连通分量。如果不属于,则将这条边加入最小生成树中,并将u和v合并到同一个连通分量中。 4. 重复步骤3,直到最小生成树中的边数达到n-1。 通过以上步骤,就可以使用Kruskal算法求解给定图的最小生成树。 参考资料: 引用:(1)度限制最小生成树和第K最短路. (poj1639) (2)最短路,最小生成树,二分图,最大流问题的相关理论(主要是模型建立和求解) (poj3155, poj2112,poj1966,poj3281,poj1087,poj2289,poj3216,poj2446 (3)最优比率生成树. (poj2728) (4)最小树形图(poj3164) (5)次小生成树. (6)无向图、有向图的最小环 。 引用:http://home.ustc.edu.cn/~zhuhcheng/ACM/segment_tree.pdf 。 引用:练习复杂一点,但也较常用的算法。 二分图匹配(匈牙利),最小路径覆盖 网络流,最小费用流。 线段树. 并查集。 熟悉动态规划的各个典型:LCS、最长递增子串、三角剖分、记忆化dp 6.博弈类算法。博弈树,二进制法等。 7.最大团,最大独立集。 8.判断点在多边形内。 差分约束系统. 双向广度搜索、A*算法,最小耗散优先. 第三阶段: 。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值