Modular Inverse 【欧几里得求 最小逆元】

2 篇文章 0 订阅

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1≡x (mod m). This is equivalent to ax≡1 (mod m).

Input
There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output
For each test case, output the smallest positive x. If such x doesn’t exist, output “Not Exist”.

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist
8

看代码吧

#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
const int MAXN =1E6;
void exgcd(int a,int b,int &x,int &y,int &d){
    if(b==0) { d=a; x=1;y=0;}
    else {
        exgcd(b,a%b,y,x,d);
        y-=(a/b)*x;
    }
}
int chi(int a,int n){
    int x,y,d;
    exgcd(a,n,x,y,d);
    if(d!=1) return -1;
    x=x%n;
    if(x<=0) x+=n;  
    return x;
}
int main(){
    int t;cin>>t;
    while(t--){
        int a,m;
        cin>>a>>m;
        int ans=chi(a,m);
        if(ans==-1) puts("Not Exist");
        else cout<<ans<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值