【POJ 3107 】Godfather 【树的重心】

Language:
Godfather
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 7652 Accepted: 2701
Description

Last years Chicago was full of gangster fights and strange murders. The chief of the police got really tired of all these crimes, and decided to arrest the mafia leaders.

Unfortunately, the structure of Chicago mafia is rather complicated. There are n persons known to be related to mafia. The police have traced their activity for some time, and know that some of them are communicating with each other. Based on the data collected, the chief of the police suggests that the mafia hierarchy can be represented as a tree. The head of the mafia, Godfather, is the root of the tree, and if some person is represented by a node in the tree, its direct subordinates are represented by the children of that node. For the purpose of conspiracy the gangsters only communicate with their direct subordinates and their direct master.

Unfortunately, though the police know gangsters’ communications, they do not know who is a master in any pair of communicating persons. Thus they only have an undirected tree of communications, and do not know who Godfather is.

Based on the idea that Godfather wants to have the most possible control over mafia, the chief of the police has made a suggestion that Godfather is such a person that after deleting it from the communications tree the size of the largest remaining connected component is as small as possible. Help the police to find all potential Godfathers and they will arrest them.

Input

The first line of the input file contains n — the number of persons suspected to belong to mafia (2 ≤ n ≤ 50 000). Let them be numbered from 1 to n.

The following n − 1 lines contain two integer numbers each. The pair ai, bi means that the gangster ai has communicated with the gangster bi. It is guaranteed that the gangsters’ communications form a tree.

Output

Print the numbers of all persons that are suspected to be Godfather. The numbers must be printed in the increasing order, separated by spaces.

Sample Input

6
1 2
2 3
2 5
3 4
3 6
Sample Output

2 3

题意,给定一棵树,求其中所有的重心序号。

糟心,用vector存图,无限TLE,改为邻接表就过了。有毒。。。

#include<stdio.h>
#include<vector>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;
#define LL long long 

const int MAXN = 5*1e5+10;
const int MAXM = 1e6;
const int inf = 0x3f3f3f3f;

struct Edge {
    int from,to,nexts;
}edge[MAXN<<2];
int head[MAXN],top;
void init(){
    memset(head,-1,sizeof(head));
    top=0;
}
void addedge(int a,int b){
    Edge e={a,b,head[a]};
    edge[top]=e;head[a]=top++;
}
int n,m;
int dp[MAXN],num[MAXN];
void dfs(int now,int pre){
    num[now]=1;
    for(int i=head[now];i!=-1;i=edge[i].nexts){
        int v=edge[i].to;
        if(v==pre) continue;
        dfs(v,now);
        num[now]+=num[v];
        dp[now]=max(dp[now],num[v]);
    }
    dp[now]=max(dp[now],n-num[now]);
}
int main(){
    scanf("%d",&n);m=n-1;
    int a,b;
    init();
    while(m--){
        scanf("%d%d",&a,&b);
        addedge(a,b);
        addedge(b,a);
    }
    dfs(1,-1);
    int sum=inf;
    for(int i=1;i<=n;  if(sum>dp[i]) sum=dp[i];

    for(int i=1;i<=n;i++) 
        if(sum==dp[i]) printf("%d ",i);
    puts("");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值