POJ 3279 Fliptile 翻转问题+搜索

http://poj.org/problem?id=3279

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题目大意: 给n*m个数,0代表白色,1代表黑色,可以翻转任意一个位置的颜色,但是同时会翻转该位置相邻四个位置的颜色,问能否把这些数全部变成白色,若能则求出操作次数最少的情况中字典序最小的那种情况。

思路: 对同一个位置操作两次及以上是没有意义的。因此考虑枚举第一行所有可能的翻转操作,因为i-1行的翻转操作已经确定了, 所以第i行的翻转操作也可以确定(因为要使第i-1行的情况满足题意),最后判断最后一行的情况是否满足题意即可。第一行从小到大枚举即可做到字典序最小。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;

int n,m;
int a[20][20];
int b[20][20]; //翻转次数
int c[20][20]; //最优解
int d[5][2]={{-1,0},{11,0},{0,0},{0,-1},{0,1}};

int getcolor(int x,int y)
{
    int tmp=a[x][y];
    int dx,dy;
    for(int i=0;i<5;i++)
    {
        dx=x+d[i][0];
        dy=y+d[i][1];
        tmp+=b[dx][dy];
    }
    return tmp%2;
}

int solve()
{
    for(int i=2;i<=n;i++)
        for(int j=1;j<=m;j++)
            if(getcolor(i-1,j)) //看上一行同列的颜色
                b[i][j]=1;
    for(int i=1;i<=m;i++)
        if(getcolor(n,i)) //看最后一行是否满足题意
            return INF;
    int ans=0;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            ans+=b[i][j];
    return ans;
}

int main()
{
    scanf("%d %d",&n,&m);
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            scanf("%d",&a[i][j]);
    int MAX=(1<<m); //枚举第一行的所有情况
    int re=INF; //记录答案
    for(int t=0;t<MAX;t++)
    {
        memset(b,0,sizeof(b));
        for(int i=1;i<=m;i++) //这样枚举也满足了字典序最小的情况
            b[1][i]=t>>(m-i)&1; //第一行的情况为 t 的二进制表示
        int tmp=solve();
        if(tmp<re)
        {
            re=tmp;
            memcpy(c,b,sizeof(b));
        }
    }
    if(re==INF)
    {
        printf("IMPOSSIBLE\n");
        return 0;
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
            printf("%d ",c[i][j]);
        printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值