【LightOJ - 1234】 Harmonic Number 【调和级数求前n项和---分块打表】

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

这里写图片描述

In this problem, you are given n, you have to find Hn.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output
For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input
12
1
2
3
4
5
6
7
8
9
90000000
99999999
100000000
Sample Output
Case 1: 1
Case 2: 1.5
Case 3: 1.8333333333
Case 4: 2.0833333333
Case 5: 2.2833333333
Case 6: 2.450
Case 7: 2.5928571429
Case 8: 2.7178571429
Case 9: 2.8289682540
Case 10: 18.8925358988
Case 11: 18.9978964039
Case 12: 18.9978964139

分析:学过数列的肯定都知道这个序列是个不收敛的,是个调和级数。看一下数据范围,最简单的我们 应该会有两种方案:
1》 打表sum[i]代表 前i项的和值
2》每次求解都从1到n求和一下。
分析一下上述 思路 ,第一种:肯定会MLE 。而第二种肯定会TLE 。这个就很尴尬。

我们用另外一种方式来表示:分块打表(分块大法好哇!!)
我们每B个数字分为一个整体,假设第 i 块的第一个数字为x,那么sum[i]表示 从第一项加到第x项 。 那么对于任意给定的n, 那么 它一定属于第 n/B 中,sum[n/B] 我们又可以o(1)得到,其余的部分我们可以逐一枚举来求得。而每一块大小为B,最坏的情况就是枚举B个,所以对于每次求解时间复杂度就降到了o(B),而空间复杂度就降到了o(MAX/B)。
(不要太在意这个题目,一定要理解分块打表的思想,确实很巧妙)
代码

#include<bits/stdc++.h>
using namespace std;
#define LL long long

const int N = (int)1e8+2;
const int M = 1E6+11;
const int mod = 1e9+7;
const int inf = 0x3f3f3f3f;

double sum[M]; int B =100;
void init(){
    double s=0;
    for(int i=1;i<N;i++){
        s+=1.0/i;
        if(i%B==0) sum[i/B]=s;
    }
}

int main(){
    init(); int cas=1;
    int T;scanf("%d",&T);
    while(T--){
        int n;scanf("%d",&n);
        double ans=sum[n/B];
        for(int i=n/B*B+1;i<=n;i++) { // 从第n/B块的第二个元素开始
            ans+=1.0/i;
        }
        printf("Case %d: %.9lf\n",cas++,ans);
    }
return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值