LightOJ - 1234 Harmonic Number【调和级数求和】

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139


调和级数求和。如果直接求的话会超时。直接打表的话会超内存。我们可以采取一种折中的方法,每100个数存一下,这样下面最多只需要遍历99次。

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double sum[1000005];
int main()
{
    double s=0;
    sum[0]=0;
    for(int i=1;i<=1e8;i++)
    {
        s+=1.0/i;
        if(i%100==0)
        {
            sum[i/100]=s;
        }
    }
    int n,cas;
    scanf("%d",&cas);
    for(int tt=1;tt<=cas;tt++)
    {
        scanf("%d",&n);
        double ans=sum[n/100];
        for(int i=(n/100)*100+1;i<=n;i++)
        {
            ans+=1.0/i;
        }
        printf("Case %d: %.10lf\n",tt,ans);
    }
    return 0;
}

还有一种更加玄学的解法。

知识点:

     调和级数(即f(n))至今没有一个完全正确的公式,但欧拉给出过一个近似公式:(n很大时)

      f(n)ln(n)+C+1/(2*n)    

      欧拉常数值:C≈0.57721566490153286060651209

      c++ math库中,log即为ln。

     n很小时直接求,此时公式不是很准。

(摘自http://www.cnblogs.com/shentr/p/5296462.html)

代码:

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const double r=0.57721566490153286060651209;     //欧拉常数
double a[10000];

int main()
{
    a[1]=1;
    for (int i=2;i<10000;i++)
    {
        a[i]=a[i-1]+1.0/i;
    }
    int n;
    cin>>n;
    for (int kase=1;kase<=n;kase++)
    {
        int n;
        cin>>n;
        if (n<10000)
        {
            printf("Case %d: %.10lf\n",kase,a[n]);
        }
        else
        {
            double a=log(n)+r+1.0/(2*n);
            //double a=log(n+1)+r;
            printf("Case %d: %.10lf\n",kase,a);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值