Harmonic Number(欧拉公式或技巧打表)LightOJ - 1234(求调和级数的和)

题意:求f(n)=1/1+1/2+1/3+1/4…1/n (1 ≤ n ≤ 108).,精确到10-8 (原题在文末) 知识点:调和级数(即f(n))至今没有一个完全正确的公式,但欧拉给出过一个近似公式:(n很大时)

f(n)≈ln(n)+C+1/2*n

欧拉常数值:C≈0.57721566490153286060651209

c++ math库中,log即为ln。

题解:公式:f(n)=ln(n)+C+1/(2*n); n很小时直接求,此时公式不是很准。 或者用打表做

题目:

In mathematics, the nth harmonic number is the sum of the reciprocals of the first n natural numbers:

In this problem, you are given n, you have to find Hn.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 108).

Output

For each case, print the case number and the nth harmonic number. Errors less than 10-8 will be ignored.

Sample Input

12

1

2

3

4

5

6

7

8

9

90000000

99999999

100000000

Sample Output

Case 1: 1

Case 2: 1.5

Case 3: 1.8333333333

Case 4: 2.0833333333

Case 5: 2.2833333333

Case 6: 2.450

Case 7: 2.5928571429

Case 8: 2.7178571429

Case 9: 2.8289682540

Case 10: 18.8925358988

Case 11: 18.9978964039

Case 12: 18.9978964139

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const double r=0.57721566490153286060651209;     //欧拉常数
double a[10000];
int main()
{
    a[1]=1;
    for (int i=2;i<10000;i++)
    {
        a[i]=a[i-1]+1.0/i;
    }
    int n;
    cin>>n;
    for (int kase=1;kase<=n;kase++)
    {
        int n;
        cin>>n;
        if (n<10000)
        {
            printf("Case %d: %.10lf\n",kase,a[n]);
        }
        else
        {
            double a=log(n)+r+1.0/(2*n);
            printf("Case %d: %.10lf\n",kase,a);
        }
    }
    return 0;
}

记不住公式,就打表做

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int M=1e8;
int t;
int m;
double w[1000010]={0.0};
int main()
{
    cin>>t;
    int k=1;
    double s=0.0;
    for(int i=1; i<=M; i++)
    {
        s+=1.0/i;
        if(i%100==0)
            w[i/100]=s;
    }
    while(t--)
    {
        cin>>m;
        int a=m/100;
        double ans=w[a];
        for(int i=a*100+1; i<=m; i++)
            ans+=1.0/i;
        printf("Case %d: %.10lf\n",k++,ans);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值