POJ 3186 Treats for the Cows 【区间DP】

Treats for the Cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7379 Accepted: 3911

Description

FJ has purchased N (1 <= N <= 2000) yummy treats for the cows who get money for giving vast amounts of milk. FJ sells one treat per day and wants to maximize the money he receives over a given period time.

The treats are interesting for many reasons:
  • The treats are numbered 1..N and stored sequentially in single file in a long box that is open at both ends. On any day, FJ can retrieve one treat from either end of his stash of treats.
  • Like fine wines and delicious cheeses, the treats improve with age and command greater prices.
  • The treats are not uniform: some are better and have higher intrinsic value. Treat i has value v(i) (1 <= v(i) <= 1000).
  • Cows pay more for treats that have aged longer: a cow will pay v(i)*a for a treat of age a.
Given the values v(i) of each of the treats lined up in order of the index i in their box, what is the greatest value FJ can receive for them if he orders their sale optimally?

The first treat is sold on day 1 and has age a=1. Each subsequent day increases the age by 1.

Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains the value of treat v(i)

Output

Line 1: The maximum revenue FJ can achieve by selling the treats

Sample Input

5
1
3
1
5
2

Sample Output

43

Hint


Explanation of the sample:

Five treats. On the first day FJ can sell either treat #1 (value 1) or treat #5 (value 2).

FJ sells the treats (values 1, 3, 1, 5, 2) in the following order of indices: 1, 5, 2, 3, 4, making 1x1 + 2x2 + 3x3 + 4x1 + 5x5 = 43.

Source


    题意:给出n个数字v(i),每次你可以取出最左边的数字或者取出最右边的数字,一共取n次取完。假设你第i次取的数字是x,那么你可以获得i*x的价值。现在你需要规划取数顺序,使得总价值和最大。

    转移方程:

        dp[i][j]  代表取    从最左边数i个连续的元素  和  从最右边数j个连续元素 所能得到的最大总价值。

        从两个状态转移而来: 1:取从左边数第i个元素    2:取从右边数第j个元素

          得出: dp[i][j] = max(dp[i-1][j]+num[i]*(i+j),dp[i][j-1]+num[n-j+1]*(j+i))

        dp[i-1][j] 代表从最左边取i-1个连续元素和从最右边取j个连续元素得到的最大价值(dp[i][j-1]同理)


        dp[i-1][j]+num[i]*(i+j) 代表第(i+j)次取从左边数第i个元素得到的价值

        dp[i][j-1]+num[n-j+1]*(j+i) 代表第(i+j)次从右边数第j个元素得到的价值 (注:从左边数第j个元素是num[n-j+1])


        当i = 0 的时候:dp[i][j] = dp[i][j-1] + num[n-j+1]*j   因为此时右边一个数不取

        当j = 0 的时候:dp[i][j] = dp[i-1][j] + num[i] * i  因为此时左边一个数不取   


#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
using namespace std;
#define ll long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN = 2e3+5;
int n,MAX;
int num[MAXN];
int dp [MAXN][MAXN];
int main()
{
    while(~scanf("%d",&n))
    {
        M(dp,0);
        for(int i=1; i<=n; i++) scanf("%d",&num[i]);
        MAX = 0;
        for(int i=0; i<=n; i++)
        {
            for(int j=0; j+i <=n; j++)
            {
                if(i>0&&j>0) dp[i][j] = max(dp[i-1][j]+num[i]*(i+j),dp[i][j-1]+num[n-j+1]*(j+i));
                else if(i>0) dp[i][j] = dp[i-1][j] + num[i] * i;
                else if(j>0) dp[i][j] = dp[i][j-1] + num[n-j+1]*j;
                MAX = max(dp[i][j],MAX);
            }

        }
        printf("%d\n",MAX);
    }
    return 0;
}
///dp[i][j] = max(dp[i-1][j]+num[i]*(i+j),dp[i][j-1]+num[n-j-1]*(j+i))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值