HDU 2612 Find a way 【bfs】

Find a way

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24292    Accepted Submission(s): 7957


 

Problem Description

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.

 

 

Input

The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF

 

 

Output

For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.

 

 

Sample Input

 

4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#

 

 

Sample Output

 

66 88 66

 

 

Author

yifenfei

 

 

Source

奋斗的年代

 

 

Recommend

yifenfei

 

/*
@代表KFC
Y和M分别是两个人的出发点
这个城镇中有很多KFC
找一个KFC作为碰面地点,使两个人到达这个KFC的时间之和尽量短

坑点: 一个人可能无法到达所有的KFC
两个人的起始点 Y和M是不能通行的。

*/
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
using namespace std;
#define LL long long
#define M(a,b) memset(a,b,sizeof(a))
const int MAXN =1500;
const int INF =  0x3f3f3f3f;
int X[15] = {0,0,0,-1,1};
int Y[15] = {0,1,-1,0,0};
queue<pair<int,int> >q;
int vis[MAXN][MAXN];
int ys[MAXN][MAXN];
int ans[MAXN][MAXN];
char MAP[MAXN][MAXN];
int n,m,flag,sum,MIN;
void init()
{
    M(vis,0);
    while(!q.empty()) q.pop();
}
void bfs(int x,int y)
{
    init();
    q.push(make_pair(x,y));
    vis[x][y] = 1;
    while(!q.empty())
    {
        int x1 = q.front().first;
        int y1 = q.front().second;
        if(MAP[x1][y1]=='@')
        {
            ys[x1][y1] ++;///记录可到达该KFC的人的数量,必须两个人都能到达该KFC的时候才有意义。
            ans[x1][y1] += (vis[x1][y1]-1);///把所有步数信息存储到数组中
        }
        q.pop();
        for(int i=1; i<=4; i++)
        {
            int xx = x1 +X[i];
            int yy = y1 +Y[i];
            if(xx>=1&&xx<=n&&yy>=1&&yy<=m&&vis[xx][yy]==0&&MAP[xx][yy]!='#'&&MAP[xx][yy]!='M'&&MAP[xx][yy]!='Y')///Y和M点也是不能走的
            {
                vis[xx][yy] = vis[x1][y1]+1;
                q.push(make_pair(xx,yy));
            }
        }
    }
    return ;
}
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        init();
        M(ans,0);
        M(ys,0);
        for(int i=1; i<=n; i++)
        {
            scanf("%s",MAP[i]+1);
        }
        sum = 0;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(MAP[i][j]=='Y')
                {
                    bfs(i,j);
                }
                else if(MAP[i][j]=='M')
                {
                    bfs(i,j);
                }
            }
        }
        MIN = INF;
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=m; j++)
            {
                if(MAP[i][j]=='@'&&ys[i][j]==2)
                {
                    MIN = min(MIN,ans[i][j]);
                }
            }

        }

        printf("%d\n",MIN*11);///要乘11
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值