HDU 4764 Stone 博弈水题

Stone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2067    Accepted Submission(s): 1458


Problem Description
Tang and Jiang are good friends. To decide whose treat it is for dinner, they are playing a game. Specifically, Tang and Jiang will alternatively write numbers (integers) on a white board. Tang writes first, then Jiang, then again Tang, etc... Moreover, assuming that the number written in the previous round is X, the next person who plays should write a number Y such that 1 <= Y - X <= k. The person who writes a number no smaller than N first will lose the game. Note that in the first round, Tang can write a number only within range [1, k] (both inclusive). You can assume that Tang and Jiang will always be playing optimally, as they are both very smart students.
 

Input
There are multiple test cases. For each test case, there will be one line of input having two integers N (0 < N <= 10^8) and k (0 < k <= 100). Input terminates when both N and k are zero.
 

Output
For each case, print the winner's name in a single line.
 

Sample Input
 
 
1 130 310 20 0
 

Sample Output
 
 
JiangTangJiang
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6263  6262  6261  6260  6259 
 

问题就是巴什博奕,共N个物品,每次可取1-k个,去到最后一个的输

首先我们找一下规律

1  后手赢

2  -   k+1  先手赢

k+2  后手赢

k+3 -   2k+2  先手赢

2k+3  后手赢

2k+4   -    3k+3  先手赢

可以看出,所有后手赢的点都满足(n-1)%(k+1)==0  (n为给定必输值)

#include<stdio.h>
typedef long long ll;
int main(){
	ll a,b;
	while(scanf("%lld%lld",&a,&b) &&  (a+b))
	{
		if( (a-1)%(b+1) == 0 )
			printf("Jiang\n");
		else
			printf("Tang\n");
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值