HDU 1301 最小生成树裸题

Jungle Roads

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10336    Accepted Submission(s): 7579


 

Problem Description


The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems. 

The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above. 

The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit. 

 

 

Sample Input

 

9 A 2 B 12 I 25 B 3 C 10 H 40 I 8 C 2 D 18 G 55 D 1 E 44 E 2 F 60 G 38 F 0 G 1 H 35 H 1 I 35 3 A 2 B 10 C 40 B 1 C 20 0

 

 

Sample Output

 

216 30

 

 

Source

Mid-Central USA 2002

 

 

Recommend

Eddy   |   We have carefully selected several similar problems for you:  1162 1102 1233 1217 1142 

第一个是PRIM算法,第二个是Cruskal算法

第一个时间复杂度为O(N^2) ,第二个为O(ElogE),其中N为点数,E为边数,当边比较多应该用Prim,否则用Cruskal

#include<bits/stdc++.h>
using namespace std;
const int maxn=30;
const int maximum=1e9+7;
int mat[maxn][maxn];
int book[maxn],cloest[maxn],lowcost[maxn];
int n;
int ans;
void inti()
{
	memset(book,0,sizeof book);
	memset(cloest,0,sizeof cloest);
	memset(lowcost,0,sizeof lowcost);
	memset(mat,0,sizeof mat);
	ans=0;
	for(int i=1;i<=n-1;i++)
	{
		int tep,num;
		char t1,t2;
		scanf(" %c%d",&t1,&tep);
		for(int i=1;i<=tep;i++)
		{
			scanf(" %c%d",&t2,&num);
			mat[t1-'A'+1][t2-'A'+1]=mat[t2-'A'+1][t1-'A'+1]=num;
		}
	}
	for(int i=1;i<=n;i++)
		for(int j=1;j<=n;j++)
		{
			if(i==j)
				mat[i][j]=0;
			else if(mat[i][j]==0)	
				mat[i][j]=maximum;
		}
} 
void Prim()
{
	book[1]=1;
	for(int i=2;i<=n;i++)
		cloest[i]=1,lowcost[i]=mat[1][i];
	for(int i=1;i<n;i++)
	{
		int t=1,tep=maximum;
		for(int j=1;j<=n;j++)
		{
			if(!book[j] && lowcost[j]<tep)
				t=j,tep=lowcost[j];
		}
		ans+=mat[t][cloest[t]];
		book[t]=1;
		for(int j=1;j<=n;j++)
		{
			if(!book[j] && mat[t][j]<lowcost[j])
				lowcost[j]=mat[t][j],cloest[j]=t;
		}
	}
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		inti();
		Prim();
		printf("%d\n",ans);
	}
	return 0;
}

 

#include<bits/stdc++.h>
using namespace std;
const int maxn=30;
const int maximum=1e9+7;
int pre[maxn],n,ans;
struct edge{
	int x,y,v;
	friend bool operator<(edge a,edge b)
	{
		return a.v>b.v;
	}
}; 
priority_queue <edge> Q;

int find(int x)
{
	return x==pre[x]?x:pre[x]=find(pre[x]);
}

void join(int x,int y)
{
	if(find(x)!=find(y))
		pre[find(x)]=find(y);
}

void inti()
{
	ans=0;
	for(int i=1;i<=n;i++)
		pre[i]=i;
	for(int i=1;i<=n-1;i++)
	{
		int tep,num;
		char t1,t2;
		scanf(" %c%d",&t1,&tep);
		for(int i=1;i<=tep;i++)
		{
			edge a,b;
			scanf(" %c%d",&t2,&num);
			a.x=t1-'A'+1; a.y=t2-'A'+1; a.v=num; Q.push(a);
			b.x=t2-'A'+1; b.y=t1-'A'+1; b.v=num; Q.push(b);
 		}
	}
} 
void Cruskal()
{
	int num=n-1;
	while(num && Q.size())
	{
		edge a=Q.top();
		Q.pop();
		if(find(a.x)!=find(a.y))
			join(a.x,a.y),ans+=a.v,num--;
	}
	while(Q.size())
		Q.pop();
}
int main()
{
	while(scanf("%d",&n)&&n)
	{
		inti();
		Cruskal();
		printf("%d\n",ans);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值