HDU 1020 Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45618    Accepted Submission(s): 20167


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 
Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 
Output
For each test case, output the encoded string in a line.
 
Sample Input
  
  
2 ABC ABBCCC
 
Sample Output
  
  
ABC A2B3C
 
               题意:
     给定一个仅包含‘A-Z’的字符串,用以下方法对它进行编码:
     1、包含K个相同字符的应编码为'KX',其中X是此子串中的唯一字符。
     2、如果子串长度为1,这忽略1。

     解题思路:
            找出子串中相同的字符,用一个计数器记录该字符出现的次数即可。若出现次数为1忽略1即可。

     注意:
      题目描述的是子串连续的的字符中各个字母的个数。而不是一整串的字符中的字母的个数

 例如:AABBBCAABCCD

       2A3BC2AB2CD

刚开始理解错题意了,错了好几遍呢!难过


代码:

#include <iostream>
#include <algorithm>
#include <map>
#include <cstdio>
#include <string>
#include <cstring>
using namespace std;
int main()
{
    int t;
    string s;
    cin>>t;
    getchar();
    while(t--)
    {
        cin>>s;
        int len=s.size();
        int ans=1;///用ans来记录字符出现的次数
        int temp=s[0];///用temp来存储第一个字符
        for(int i=1; i<=len; i++)///将temp与后边的字符进行比较,相同的ans++
        {
            if(s[i]!=temp)
            {
                if(ans==1)///如果次数为1,忽略1,直接输出
                {
                    cout<<s[i-1];
                    temp=s[i];
                }
                else
                {
                    cout<<ans<<s[i-1];
                    temp=s[i];
                    ans=1;
                }
            }
            else
                ans++;
        }
        cout<<endl;
    }
    return 0;
}



  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值