HDU 4968 Improving The GPA

Improving the GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 820    Accepted Submission(s): 586


Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.


The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.
 

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
 

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
 

Sample Input
 
 
475 175 275 375 10
 

Sample Output
 
 
3.0000 3.00002.7500 3.00002.6667 3.16672.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale.For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667
 

Author
SYSU
 

Source
#include<iostream>
#include<queue>
#include<stdio.h>
#include<cstring>
#include<cmath>
using namespace std;
typedef long long LL;
#define maxn 10000000
int AVG,N,sum;
double dp[11][1005],tmp[11][1005];
double mp[101];
double lans,uans;
int main()
{
    for(int i=0;i<101;i++)
    {
        if(i<60) mp[i]=-1000;//
        if(i>=60&&i<70) mp[i]=2.0;
        if(i>=70&&i<75) mp[i]=2.5;
        if(i>=75&&i<80) mp[i]=3.0;
        if(i>=80&&i<85) mp[i]=3.5;
        if(i>=85) mp[i]=4.0;
    }
    int t;cin>>t;
    while(t--)
    {
        cin>>AVG>>N;
        sum=AVG*N;
        for(int i=0;i<=100;i++)  dp[1][i]=tmp[1][i]=mp[i];
        for(int i=2;i<=N;i++)
            for(int j=(i-1)*60+1;j<=sum;j++)
        {
            dp[i][j]=10000;
            tmp[i][j]=-1;
            for(int k=60;k<=100;k++)
            {
                if(dp[i-1][j-k]> 0) dp[i][j]=min(dp[i][j],dp[i-1][j-k]+mp[k]);

                 if(tmp[i-1][j-k]> 0) tmp[i][j]=max(tmp[i][j],tmp[i-1][j-k]+mp[k]);
            }
        }
        lans=dp[N][sum]/N;
        uans=tmp[N][sum]/N;
        printf("%.4f %.4f\n",lans,uans);
    }
    return 0;
}

 

Recommend
We have carefully selected several similar problems for you:   6275  6274  6273  6272  6271 
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值