hdu 4968 Improving the GPA--2014 Multi-University Training Contest 9

79 篇文章 0 订阅

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4968


Improving the GPA

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 70    Accepted Submission(s): 47


Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.

In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N

where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.

To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.

In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them. 


The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N

So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale. 
 

Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
 

Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
 

Sample Input
  
  
4 75 1 75 2 75 3 75 10
 

Sample Output
  
  
3.0000 3.0000 2.7500 3.0000 2.6667 3.1667 2.4000 3.2000
Hint
In the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale. For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667 Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667 Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667 Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   4969  4967  4966  4964  4963 
 

Statistic |  Submit |  Discuss |  Note

一道贪心的题目。也算是这场的水题了。

#include<stdio.h>
int main(){
    int t;
    while(~scanf("%d",&t)){
        while(t--){
            double mi=0,ma=0;int x,y;
            scanf("%d%d",&x,&y);
            int tmp=(x-85)*y;x=(x-69)*y;
            if(x<=0) mi=2.0*y;
            else{
                mi=2.0*y;
                for(;x>0;){
                    if(x>15){mi+=2.0;x-=31;}
                    else if(x>10){mi+=1.5;x-=15;}
                    else if(x>7){mi+=1.0;x-=10;}
                    else if(x>0){mi+=0.5;x-=5;}
                }
            }
            if(tmp>=0) ma=4.0*y;
            else {
                ma=4.0*y;
                for(;tmp<0;){
                    if(tmp<-15){ma-=2.0;tmp+=25;}
                    else if(tmp<-10){ma-=1.5;tmp+=15;}
                    else if(tmp<-5){ma-=1.0;tmp+=10;}
                    else if(tmp<0){ma-=0.5;tmp+=5;}
                }
            }
            printf("%.4lf %.4lf\n",mi/y,ma/y);
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值