hdu 4968 Improving the GPA
Improving the GPA
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)Total Submission(s): 347 Accepted Submission(s): 279
Problem Description
Xueba: Using the 4-Point Scale, my GPA is 4.0.
In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
AVERAGE SCORE = ∑(Wi * SCOREi) / ∑(Wi) 1<=i<=N
where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.
To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.
In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.
The student’s average GPA in the 4-Point Scale is calculated as follows:
GPA = ∑(GPAi) / N
So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.
In fact, the AVERAGE SCORE of Xueba is calculated by the following formula:
where SCOREi represents the scores of the ith course and Wi represents the credit of the corresponding course.
To simplify the problem, we assume that the credit of each course is 1. In this way, the AVERAGE SCORE is ∑(SCOREi) / N. In addition, SCOREi are all integers between 60 and 100, and we guarantee that ∑(SCOREi) can be divided by N.
In SYSU, the university usually uses the AVERAGE SCORE as the standard to represent the students’ level. However, when the students want to study further in foreign countries, other universities will use the 4-Point Scale to represent the students’ level. There are 2 ways of transforming each score to 4-Point Scale. Here is one of them.
The student’s average GPA in the 4-Point Scale is calculated as follows:
So given one student’s AVERAGE SCORE and the number of the courses, there are many different possible values in the 4-Point Scale. Please calculate the minimum and maximum value of the GPA in the 4-Point Scale.
Input
The input begins with a line containing an integer T (1 < T < 500), which denotes the number of test cases. The next T lines each contain two integers AVGSCORE, N (60 <= AVGSCORE <= 100, 1 <= N <= 10).
Output
For each test case, you should display the minimum and maximum value of the GPA in the 4-Point Scale in one line, accurate up to 4 decimal places. There is a space between two values.
Sample Input
4 75 1 75 2 75 3 75 10
Sample Output
3.0000 3.0000 2.7500 3.0000 2.6667 3.1667 2.4000 3.2000HintIn the third case, there are many possible ways to calculate the minimum value of the GPA in the 4-Point Scale. For example, Scores 78 74 73 GPA = (3.0 + 2.5 + 2.5) / 3 = 2.6667 Scores 79 78 68 GPA = (3.0 + 3.0 + 2.0) / 3 = 2.6667 Scores 84 74 67 GPA = (3.5 + 2.5 + 2.0) / 3 = 2.6667 Scores 100 64 61 GPA = (4.0 + 2.0 + 2.0) / 3 = 2.6667
题目如上 给出n门科目的平均成绩 求出最小的以及最大的gpa的平均值
第一眼看到的感觉就是贪心吧 暴力应该是可以的 后来没细想
在70到84之间都是5分一个档次 此消彼长 对gpa的总和不会产生影响 所以应该考虑60-69和85-100这个区间内的变化
要取得最小值 尽可能多的去取69 然后尽可能的去取100 在此情况下可使分数的分配最差 注意当初始化使所有值都为69时 sum的值小于等于0时 这个时候的gpa平均值应为2.0 因为给出的平均值是大于等于60的 所以不会出现0的情况
要取得最大值 尽可能的去取65 然后尽可能的去取85 这种情况下分数的分配最优
代码比较简单
#include <cstdio>
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string.h>
#include <string>
#define eps 1e-8
#define op operator
#define MOD 10009
#define MAXN 5010
#define FOR(i,a,b) for(int i=a;i<=b;i++)
#define FOV(i,a,b) for(int i=a;i>=b;i--)
#define REP(i,a,b) for(int i=a;i<b;i++)
#define REV(i,a,b) for(int i=a-1;i>=b;i--)
#define MEM(a,x) memset(a,x,sizeof a)
#define ll __int64
using namespace std;
double func(int m)
{
if(m<60) return 0;
if(m<70) return 2.0;
if(m<75) return 2.5;
if(m<80) return 3.0;
if(m<85) return 3.5;
else return 4.0;
}
int num,n;
int x[MAXN];
void max_gpa()
{
int sum=num*n;
for(int i=0;i<n;i++)
x[i]=60;
sum-=n*60;
double maxav=0.0;
for(int i=0;i<n;i++)
{
int tmp=min(sum,85-60);
x[i]+=tmp;
sum-=tmp;
maxav+=func(x[i]);
}
printf("%.4lf\n",maxav/(n*1.0));
}
void min_gpa()
{
int sum=num*n;
sum-=n*69;
double minav=0.0;
if(sum<=0)
{
printf("%.4lf ",2.0);
return;
}
for(int i=0;i<n;i++)
x[i]=69;
for(int i=0;i<n;i++)
{
int tmp=min(100-69,sum);
sum-=tmp;
x[i]+=tmp;
minav+=func(x[i]);
}
printf("%.4lf ",minav/(n*1.0));
}
int main()
{
//freopen("ceshi.txt","r",stdin);
int tc;
scanf("%d",&tc);
while(tc--)
{
scanf("%d%d",&num,&n);
min_gpa();
max_gpa();
}
return 0;
}