UVA 1151 买还是建(最小生成树+子集枚举+贪心)

World Wide Networks (WWN) is a leading company that operates large telecommunication networks. WWN would like to setup a new network in Borduria, a nice country that recently managed to get rid of its military dictator Kurvi-Tasch and which is now seeking for investments of international companies (for a complete description of Borduria, have a look to the following Tintin albums “King Ottokar’s Sceptre”, “The Calculus Affair” and “Tintin and the Picaros”). You are requested to help WWN todecide how to setup its network for a minimal total cost.
There are several local companies running small networks (called subnetworks in the following) that partially cover the n largest cities of Borduria. WWN would like to setup a network that connects all n cities. To achieve this, it can either build edges between cities from scratch or it can buy one or several subnetworks from local companies. You are requested to help WWN to decide how to setup its network for a minimal total cost. • All n cities are located by their two-dimensional Cartesian coordinates. • There are q existing subnetworks. If q ≥ 1 then each subnetwork c (1 ≤ c ≤ q) is defined by a set of interconnected cities (the exact shape of a subnetwork is not relevant to our problem). • A subnetwork c can be bought for a total cost wc and it cannot be split (i.e., the network cannot be fractioned). • To connect two cities that are not connected through the subnetworks bought, WWN has to build an edge whose cost is exactly the square of the Euclidean distance between the cities.
You have to decide which existing networks you buy and which edges you setup so that the total cost is minimal. Note that the number of existing networks is always very small (typically smaller than 8).
Input
The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
Each test case is described by one input file that contains all the relevant data. The first line contains the number n of cities in the country (1 ≤ n ≤ 1000) followed by the number q of existing subnetworks (0 ≤ q ≤ 8). Cities are identified by a unique integer value ranging from 1 to n. The first line is followed by q lines (one per subnetwork), all of them following the same pattern: The first integer is the number of cities in the subnetwork. The second integer is the the cost of the subnetwork (not greater than 2×106). The remaining integers on the line (as many as the number of cities in the subnetwork) are the identifiers of the cities in the subnetwork. The last part of the file contains n lines that provide the coordinates of the cities (city 1 on the first line, city 2 on the second one, etc). Each line is made of 2 integer values (ranging from 0 to 3000) corresponding to the integer coordinates of the city.
Output
For each test case, your program has to write the optimal total cost to interconnect all cities. The outputs of two consecutive cases will be separated by a blank line.
A 115 Cities Instance Consider a 115 cities instance of the problem with 4 subnetworks (the 4 first graphs in Figure 1). As mentioned earlier the exact shape of a subnetwork is not relevant still, to keep figures easy to read, we have assumed an arbitrary tree like structure for each subnetworks. The bottom network in Figure 1 corresponds to the solution in which the first and the third networks have been bought. Thin edges correspond to edges build from scratch while thick edges are those from one of the initial networks.
Figure 1: A 115 Cities Instance and a Solution (Buying the First and the Third Network)
Sample Explanation: The sample input instance is shown in Figure 2. An optimal solution is described in Figure 3 (thick edges come from an existing network while thin edges have been setup from scratch).
Figure 2: The 7 City instance of the sample input
Figure 3
An optimal solution of the 7 City instance in which which the first and second existing networkshave been bought while two extra edges (1,5) and (2,4) have been setup
Sample Input
1
7 3 2 4 1 2 3 3 3 6 7 3 9 2 4 5 0 2 4 0 2 0 4 2 1 3 0 5 4 4
Sample Output
17 

#include<iostream>
#include<algorithm>
#include<string>
#include<map>//int dx[4]={0,0,-1,1};int dy[4]={-1,1,0,0};
#include<queue>//int gcd(int a,int b){return b?gcd(b,a%b):a;}
#include<vector>
#include<cmath>
#include<stack>
#include<string.h>
#include<stdlib.h>
#include<cstdio>
#define mod 1e9+7
#define ll unsigned long long
#define MAX 1000000000
#define ms memset
#define maxn 1000005
using namespace std;

int n,m,x,k;
struct edge
{
    int a,b;
    double w;
    edge(int x=0,int y=0,double  z=0)
    {
        a=x;
        b=y;
        w=z;
    }
};

bool cmp(edge e1,edge e2)
{
    return e1.w<e2.w;
}

/*
题目大意:给定n个点的坐标,
和m种套餐策略,要求如何建立最优的连通方案。

不难想到子集枚举套餐,
然后把套餐中的点边全部用权重为0的边代替,
然后和对于每个套餐的枚举,
再遍历事先得到的最小生成树的边集合,累加答案,
就可以得到最优的套餐策略。
*/

int pre[maxn];
int Find(int x) { return x==pre[x]?x:pre[x]=Find(pre[x]); }
bool Union(int x,int y)
{
    int tx=Find(x),ty=Find(y);
    if(tx==ty) return false;
    pre[tx]=ty;
    return true;
}

edge e[maxn],kual[maxn],tc[maxn];///完全图的边集合
int taocan[10][1005],cost[20];

int dx[maxn],dy[maxn];
int dist(int i,int j)
{
    int ret=0;
    int x1=dx[i],y1=dy[i];
    int x2=dx[j],y2=dy[j];
    ret=(x1-x2)*(x1-x2)+(y1-y2)*(y1-y2);
    return ret;
}

int ans=0;

int main()
{
    int t;scanf("%d",&t);
    for(int ca=1;ca<=t;ca++)
    {
        scanf("%d%d",&n,&m);
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&k,&cost[i]);
            taocan[i][0]=k;
            for(int j=1;j<=k;j++)
            {
                scanf("%d",&x);
                taocan[i][j]=x;///记录套餐的组合
            }
        }

        for(int i=0;i<n;i++) scanf("%d%d",&dx[i],&dy[i]);

        if(ca!=1) puts("");///每个样例之间空一行

        int cnt=0,index=0;///完全图,生成树
        for(int i=0;i<n;i++)
            for(int j=i+1;j<n;j++)
                e[cnt++]=edge(i+1,j+1,dist(i,j));///完全图的边集合

        sort(e,e+cnt,cmp);
        for(int i=1;i<=n;i++) pre[i]=i;
        for(int i=0;i<cnt;i++)  if(Union(e[i].a,e[i].b)) kual[index++]=e[i],ans+=e[i].w;

        ans=2e9;
        for(int i=0;i<(1<<m);i++)///枚举子集
        {
            int cst=0;
            for(int j=1;j<=n;j++) pre[j]=j;

            for(int j=0;j<m;j++)
            {
                if(i&(1<<j))
                {
                    cst+=cost[j];
                    for(int p=2;p<=taocan[j][0];p++)  Union(taocan[j][p],taocan[j][p-1]);
                }
            }

            for(int j=0;j<index;j++)   if(Union(kual[j].a,kual[j].b)) cst+=kual[j].w;
            ans=min(ans,cst);
        }
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值