HDU 5532 Almost Sorted Array(最长不下降子序列nlogn模板)

14 篇文章 0 订阅

We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array. 

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an a1,a2,…,an, is it almost sorted?
Input
The first line contains an integer  T T indicating the total number of test cases. Each test case starts with an integer  n n in one line, then one line with  n n integers  a1,a2,,an a1,a2,…,an

1T2000 1≤T≤2000 
2n105 2≤n≤105 
1ai105 1≤ai≤105 
There are at most 20 test cases with  n>1000 n>1000.
Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
Sample Output
YES
YES
NO


题解:

题意:

给你一个序列,让你从里面去掉一个使获得的序列为不上升或者为不下降序列

思路:

直接求最长不下降和不上升序列,看长度值是否为n或者n-1,模板走起

代码:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
#include<algorithm>
#define ll long long
#define INF 100861111
#define M (t[k].l+t[k].r)/2
#define lson k*2
#define rson k*2+1
using namespace std;
const int N = 100001;
int  a[N],b[N],f[N], d[N];	// f[i]用于记录 a[0...i]的最大长度
int bsearch(const int *f, int size, const int &a)
{
    int  l=0, r=size-1;
	while( l <= r )
	{
        int  mid = (l+r)>>1;
		if( a >= d[mid-1] && a < d[mid] )
			return mid;				// >&&<= 换为: >= && <
		else if( a <d[mid] )
				r = mid-1;
        else l = mid+1;
    }
}
int LIS(const int *a, const int &n)
{
	int  i, j, size = 1;
	d[0] = a[0]; f[0] = 1;
	for( i=1; i < n; ++i )
	{
		if( a[i] < d[0] )			 // <= 换为: <
			j = 0;
		else if( a[i] >= d[size-1] ) // > 换为: >=
			j = size++;
		else
			j = bsearch(d, size, a[i]);

		d[j] = a[i]; f[i] = j+1;
	}
	return size;
}
int main()
{
    int n,i,test;
    scanf("%d",&test);
    while(test--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            b[n-i-1]=a[i];
        }
        if(LIS(a,n)>=n-1||LIS(b,n)>=n-1)
        {
            printf("YES\n");
            continue;
        }
        printf("NO\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值