Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an , is it almost sorted?
We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,…,an , is it almost sorted?
Input
The first line contains an integer
T
indicating the total number of test cases. Each test case starts with an integer
n
in one line, then one line with
n
integers
a1,a2,…,an
.
1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000 .
1≤T≤2000
2≤n≤105
1≤ai≤105
There are at most 20 test cases with n>1000 .
Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
Sample Input
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
Sample Output
YES YES NO
题目大意:一组数列,去掉一个数之后能不能形成一个非递增或者非递减的数列
比赛的时候我们仨在这道题上卡了不少时间,交了31次才过的2333,我和另一个队友交了好多次都是TLE,队长的一直是WA,不过最后被队长A掉了(膜)赛后看了他的代码,不得不膜,后来在网上发现还有另一种做法,LCS!妈呀,当时看到这个我就懂了,赶紧写了一发提交,结果超时QAQ,然后发现,效率太低,O(n^2)超时正常啊,人家1e5个输入啊QAQ,最终,我发现,原来,,,求最长上升子序列还有O(nlogn)的算法... 为什么书上没有说呢?!不过,看了一下分析和代码,确实比O(n^2)的复杂一点,没那么好懂,不过确实效率确实上来了,改完提交就AC了(^_^) 所以本题有两种方法~
方法一:
比赛的时候我们仨在这道题上卡了不少时间,交了31次才过的2333,我和另一个队友交了好多次都是TLE,队长的一直是WA,不过最后被队长A掉了(膜)赛后看了他的代码,不得不膜,后来在网上发现还有另一种做法,LCS!妈呀,当时看到这个我就懂了,赶紧写了一发提交,结果超时QAQ,然后发现,效率太低,O(n^2)超时正常啊,人家1e5个输入啊QAQ,最终,我发现,原来,,,求最长上升子序列还有O(nlogn)的算法... 为什么书上没有说呢?!不过,看了一下分析和代码,确实比O(n^2)的复杂一点,没那么好懂,不过确实效率确实上来了,改完提交就AC了(^_^) 所以本题有两种方法~
方法一:
#include <iostream>
#include <cstdio>
const int N = 1e5 + 5;
using namespace std;
int a[N],n;
bool judge1()
{
bool tag = true;
a[0] = -N;
a[n+1] = N;
for(int i = 2; i <= n; i++)
{
if(a[i-1] > a[i])
{
if(!tag)
return false;
tag = false;
if(a[i+1] >= a[i-1] || a[i] >= a[i-2])
continue;
else
return false;
}
}
return true;
}
bool judge2()
{
bool tag = true;
a[0] = N;
a[n+1] = -N;
for(int i = 2; i <= n; i++)
{
if(a[i-1] < a[i])
{
if(!tag)
return false;
tag = false;
if(a[i+1] <= a[i-1] || a[i] <= a[i-2])
continue;
else
return false;
}
}
return true;
}
int main()
{
int t;
cin >> t;
while(t--)
{
cin >> n;
for(int i = 1; i <= n; i++)
scanf("%d",&a[i]);
if(judge1() || judge2())
cout << "YES\n";
else
cout << "NO\n";
}
return 0;
}
方法二:
#include <iostream>
#include <cstdio>
using namespace std;
const int N = 1e5 + 5;
int k[N];
int n;
int BiSearch(int num,int low,int high)
{
int mid;
while(low <= high)
{
mid = (low+high)/2;
if(num >= k[mid])
low= mid+1;
else
high = mid-1;
}
return low;
}
bool judge(int a[])
{
int len,pos;
k[1] = a[1];
len = 1;
for(int i = 2;i <= n;i++)
{
if(a[i] >= k[len])
{
len = len+1;
k[len] = a[i];
}
else
{
pos = BiSearch(a[i],1,len);
k[pos] = a[i];
}
}
if(len >= n-1)
return true;
else
return false;
}
int main()
{
int t;
int a[N],b[N];
cin >> t;
while(t--)
{
cin >> n;
for(int i = 1;i <= n;i++)
{
scanf("%d",&a[i]);
b[n-i+1] = a[i];
}
if(judge(a) || judge(b))
cout << "YES\n";
else
cout << "NO\n";
}
}