ZOJ 3768 Continuous Login(找规律+哈希)

3 篇文章 0 订阅

Pierre is recently obsessed with an online game. To encourage users to log in, this game will give users a continuous login reward. The mechanism of continuous login reward is as follows: If you have not logged in on a certain day, the reward of that day is 0, otherwise the reward is the previous day's plus 1.

On the other hand, Pierre is very fond of the number N. He wants to get exactly Npoints reward with the least possible interruption of continuous login.

Input

There are multiple test cases. The first line of input is an integer T indicates the number of test cases. For each test case:

There is one integer N (1 <= N <= 123456789).

Output

For each test case, output the days of continuous login, separated by a space.

This problem is special judged so any correct answer will be accepted.

Sample Input
4
20
19
6
9
<h4< dd="">
Sample Output
4 4
3 4 2
3
2 3
Hint

20 = (1 + 2 + 3 + 4) + (1 + 2 + 3 + 4)

19 = (1 + 2 + 3) + (1 + 2 + 3 + 4) + (1 + 2)

6 = (1 + 2 + 3)

9 = (1 + 2) + (1 + 2 + 3)

Some problem has a simple, fast and correct solution.



题解:

列几组数据可以发现最多有3组组成一个数字,然后就打表,用map记录下该数字下是加到几的结果,然后分三种情况:第一种是一个数字就可以组成,这个直接哈希判断就好,第二种是两个数字组成,这个用枚举第一个数字+第二个哈希判断就好了,第三种是三个数字组成,枚举前两个第三个数字用哈希判断

代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<stdlib.h>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#include<stdio.h>
using namespace std;
#define ll long long
map<int,int>M;
int a[15750];
void init()
{
    int i,j,s=0;
    for(i=1;i<=15720;i++)
    {
        s+=i;
        M[s]=i;
        a[i]=s;
    }
}
int main()
{
    int i,j,k,n,test,tag;
    init();
    while(scanf("%d",&test)!=EOF)
    {
        while(test--)
        {
            scanf("%d",&n);
            if(M[n])
            {
                printf("%d\n",M[n]);
            }
            else
            {
                tag=0;
                for(i=1;a[i]<n;i++)
                {
                    if(M[n-a[i]])
                    {
                        printf("%d %d\n",i,M[n-a[i]]);
                        tag=1;
                        break;
                    }
                }
                if(!tag)
                {
                    for(i=1;a[i]<n;i++)
                    {
                        for(j=1;a[i]+a[j]<n;j++)
                        {
                            if(M[n-a[i]-a[j]])
                            {
                                printf("%d %d %d\n",i,j,M[n-a[i]-a[j]]);
                                goto loop;
                            }
                        }
                    }
                    loop:;
                }
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值