CF788A Functions again

题目描述
Something happened in Uzhlyandia again… There are riots on the streets… Famous Uzhlyandian superheroes Shean the Sheep and Stas the Giraffe were called in order to save the situation. Upon the arriving, they found that citizens are worried about maximum values of the Main Uzhlyandian Function f f , which is defined as follows:

In the above formula, 1<=l<r<=n must hold, where n n is the size of the Main Uzhlyandian Array a a , and ∣x∣ means absolute value of x . But the heroes skipped their math lessons in school, so they asked you for help. Help them calculate the maximum value of f among all possible values of l l and r r for the given array a .

输入输出格式
输入格式:
The first line contains single integer n ( 2<=n<=10^5) — the size of the array a.
The second line contains n integers a1, a2, …, an (-10^9 ≤ ai ≤ 10^9) — the array elements.

输出格式:
Print the only integer — the maximum value of f .

输入输出样例
输入样例#1:
5
1 4 2 3 1
输出样例#1:
3
输入样例#2:
4
1 5 4 7
输出样例#2:
6
说明
In the first sample case, the optimal value of f is reached on intervals [1,2] and [2,5] .

In the second case maximal value of f is reachable only on the whole array.
如果奇数位开始,那么奇数位必为正,偶数位必为负

反之,如果从偶数位开始,那么偶数位必为正,奇数位也必为负

只要分奇偶循环各自走一遍,求最大和就好了

#include <bits/stdc++.h>
using namespace std;
const int maxn = 2e6 + 5;
typedef long long ll;
int a[maxn], b[maxn];
ll find(int l, int r) {
	ll res = 0, ans = b[l];
	for (int i = l; i <= r; i++) {
		if (res < 0) res = 0;
		res += b[i];
		ans = max(ans, res);
	}
	return ans;
}
int main() {
	int n, m;
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		scanf("%d", &a[i]);
	}
	for (int i = 1; i <= n - 1; i++) {
		if (i & 1)b[i] = abs(a[i] - a[i + 1]);
		else b[i] -= abs(a[i] - a[i + 1]);
	}
	ll ans = 0;
	ans = max(ans, find(1, n - 1));
	for (int i = 1; i <= n - 1; i++) b[i] = -b[i];
	ans = max(ans, find(1, n - 1));
	printf("%lld\n", ans);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值