EF算法求最大流

hdu3549

Flow Problem

Time Limit: 5000/5000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 19797    Accepted Submission(s): 9320


Problem Description
Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.
 

Input
The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)
 

Output
For each test cases, you should output the maximum flow from source 1 to sink N.
 

Sample Input
 
 
2 3 2 1 2 1 2 3 1 3 3 1 2 1 2 3 1 1 3 1
 

Sample Output
 
 
Case 1: 1 Case 2: 2
 

Author
HyperHexagon

AC代码:

#include<iostream>
#include<string.h>
#include<stdio.h>
#define inf 0x3f3f3f3f
using namespace std;
int n,m;
int map[20][20];
int t;
int x,y,c;
bool check[20];
int flow;
int dfs(int s,int t,int f)
{
    if(s==t)
        return f;
    check[s]=true;
    for(int i=1;i<=n;i++)
    {
        if(!check[i]&&map[s][i]>0&&i!=s)
        {
            int d=dfs(i,t,min(f,map[s][i]));
            if(d>0)
            {
                map[s][i]=map[s][i]-d;
                map[i][s]=map[i][s]+d;
                return d;
            }
        }
    }
    return 0;
}
int main()
{
    scanf("%d",&t);
    int cas=0;
    while(t--)
    {
        flow=0;
        memset(map,0,sizeof(map));
        cas++;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&c);
            map[x][y]=map[x][y]+c;
        }
        while(1)
        {
            memset(check,false,sizeof(check));
            int f=dfs(1,n,inf);
            if(f==0)
                break;
            flow=flow+f;
        }
        printf("Case %d: %d\n",cas,flow);
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值