Trailing Zeroes (III)

 

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

感悟:求一个数的n阶末尾0的数目,只需连续除以5,每除一次count加上每步除的结果。重要公式(记住就行)。。。。

#include<cstdio>
long long sum(long long n){
    long long ans=0;
    while(n){
        ans+=n/5;
        n=n/5;
    }
    return ans;
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        long long Q;
        scanf("%lld",&Q);
        long long left=1,right=1000000000;
        long long ans=0;
        while(left<=right){
            long long mid=(right+left)/2;
            if(sum(mid)==Q){
                ans=mid;
                right=mid-1;
            }else if(sum(mid)>Q){
                right=mid-1;
            }else{
                left=mid+1;
            }
        }
        printf("Case %d: ",i);
        if(ans){
            printf("%lld\n",ans);
        }else{
            printf("impossible\n");
        }
    }
    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值