PAT 1071 Speech Patterns (25)

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return '\n'. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

解答:这道题首先要理解到位,题意是找出一个字符串中的单词及词频,单词被non-alnum字符分隔,我刚开始根据测试用例以为是双引号里的字符串,其实是不对的。其次,该用哪种数据结构,我刚开始使用vector来存储,通过遍历查找,没找到便插入,逻辑上绝对没问题,但有一个测试用例超时,代码如下一。真的很sad!然后不得不使用map,终于AC了。 

超时代码:

#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
#include<sstream>
#include<cctype>
#include<algorithm>
#include<map>

using namespace std;

typedef struct{
	string str;
	int count;
}dic;

bool isMore(dic w1, dic w2)
{
	return w1.count > w2.count;
}
int main()
{
	string s, word; 
	stringstream ss;
	vector<dic> words;
	
	getline(cin, s);
	ss.str(s);
	
	while(ss >> word)
	{
		while( word.size() && !isalnum( word.back() ) ) word.pop_back();
		while( word.size() && !isalnum( word.front() ) ) word = word.substr(1);
		for(int i = 0; i < word.size(); ++i)
		{
			if( isupper(word[i]) ) word[i] = tolower(word[i]);
		}
		//添加到vector中 
		int i;
		for(i = 0; i < words.size(); ++i)
		{
			if(words[i].str == word){
				words[i].count++;
				break;
			}
		}
		if(i >= words.size())
		{
			dic tmp; tmp.str = word; tmp.count = 1;
			words.push_back(tmp);
		}
	}
	sort(words.begin(), words.end(), isMore);
	printf("%s %d\n", words[0].str.c_str(), words[0].count);
	return 0;
}

AC代码如下:

#include<cstdio>
#include<iostream>
#include<vector>
#include<string>
#include<sstream>
#include<cctype>
#include<algorithm>
#include<map>

using namespace std;


int main()
{
	string s, word = ""; 
	stringstream ss;
	map<string, int> words;
	
	getline(cin, s);
	ss.str(s);
	char ch, pre;
	
	while(ss.get(ch))
	{
		if( isalnum( ch ) ) word.push_back(ch);
		else
		{
			for(int i = 0; i < word.size(); ++i)
			{
				if( isupper(word[i]) ) word[i] = tolower(word[i]);
			}
			//添加到map中 
			if( isalnum(pre) ) words[word]++;
			word = "";
		}
		pre = ch;
	}
	if(word != "") words[word]++;
	int max = 0; string lookfor = "";
	for(map<string, int>::iterator iter = words.begin(); iter != words.end(); ++iter)
	{
		//printf("%s %d\n", iter->first.c_str(), iter->second);
		if(iter->second > max) {
			max = iter->second;
			lookfor = iter->first;
		}
	}
	//printf("lookfor:%s\n", lookfor.c_str()); 
	printf("%s %d\n", lookfor.c_str(), max);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值