NYOJ-1556 - A^BProblem【贪心】

题目描述 Give you two numbers a and b,how to know the a^b's the last digit number.It looks so easy,but everybody is too lazy to slove this problem,so they remit to you who is wise.输入There are mutiple test cases. Each test cases consists of two numbers a and b(0<=a,b<2^30)输出For each test case, you should output the a^b's last digit number.样例输入
7 66
8 800
样例输出
9
6
提示

There is no such case in which a = 0 && b = 0。

#include<iostream>
#include<algorithm>
using namespace std;
struct Node{
 int v, w;
}a[15];
bool cmp(Node a, Node b){
 return a.v > b.v;
}
int main()
{
    int n;
    cin >> n;
    while(n--){
        int s, m;
        cin >> s >> m;
        for (int i = 0; i < s; i++){
            cin >> a[i].v >> a[i].w;
        }
        sort(a, a + s, cmp);
        int ans = 0;
        for (int i = 0; i < s; i++){
            if(a[i].w > m){
                ans += m * a[i].v;
                break;
            }
            else{
                ans += a[i].w * a[i].v;
                m -= a[i].w;
            }
        }
        cout << ans << endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值