Emag eht htiw Em Pleh

Emag eht htiw Em Pleh

 

This problem is a reverse case of the  problem 2996. You are given the output of the problem H and your task is to find the corresponding input.
Input
according to output of  problem 2996.
Output
according to input of  problem 2996.
Sample Input
White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6
Sample Output
+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

水题,模拟一下即可,代码如下

#include<stdio.h>
#include<string.h>
int main()
{
	char map[][50]={
	"+---+---+---+---+---+---+---+---+", 
	"|...|:::|...|:::|...|:::|...|:::|", 
	"+---+---+---+---+---+---+---+---+", 
	"|:::|...|:::|...|:::|...|:::|...|", 
	"+---+---+---+---+---+---+---+---+", 
	"|...|:::|...|:::|...|:::|...|:::|", 
	"+---+---+---+---+---+---+---+---+", 
	"|:::|...|:::|...|:::|...|:::|...|", 
	"+---+---+---+---+---+---+---+---+", 
	"|...|:::|...|:::|...|:::|...|:::|", 
	"+---+---+---+---+---+---+---+---+", 
	"|:::|...|:::|...|:::|...|:::|...|", 
	"+---+---+---+---+---+---+---+---+", 
	"|...|:::|...|:::|...|:::|...|:::|", 
	"+---+---+---+---+---+---+---+---+", 
	"|:::|...|:::|...|:::|...|:::|...|", 
	"+---+---+---+---+---+---+---+---+"};
	char a[100];
	gets(a);
	for(int i=0;a[i]!='\0';i++)
	{
		if(a[i]==' '||a[i]==',')
		{
			if(a[i+1]=='a'||a[i+1]=='b'||a[i+1]=='c'||a[i+1]=='d'||a[i+1]=='e'||a[i+1]=='f'||a[i+1]=='g'||a[i+1]=='h')
				map[(8-(a[i+2]-'0'))*2+1][4*(a[i+1]-'a'+1)-1-1]='P';
			else
				map[(8-(a[i+3]-'0'))*2+1][4*(a[i+2]-'a'+1)-1-1]=a[i+1]; 
		}
	}
	gets(a);
	for(int i=0;a[i]!='\0';i++)
	{
		if(a[i]==' '||a[i]==',')
		{
			if(a[i+1]=='a'||a[i+1]=='b'||a[i+1]=='c'||a[i+1]=='d'||a[i+1]=='e'||a[i+1]=='f'||a[i+1]=='g'||a[i+1]=='h')
				map[(8-(a[i+2]-'0'))*2+1][4*(a[i+1]-'a'+1)-1-1]='p';
			else
				map[(8-(a[i+3]-'0'))*2+1][4*(a[i+2]-'a'+1)-1-1]=a[i+1]+32; 
		}
	}
	for(int i=0;i<17;i++)
		puts(map[i]);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值