POJ 2993 - Emag eht htiw Em Pleh

Emag eht htiw Em Pleh
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3311 Accepted: 2173

Description

This problem is a reverse case of the  problem 2996. You are given the output of the problem H and your task is to find the corresponding input.

Input

according to output of  problem 2996.

Output

according to input of  problem 2996.

Sample Input

White: Ke1,Qd1,Ra1,Rh1,Bc1,Bf1,Nb1,a2,c2,d2,f2,g2,h2,a3,e4
Black: Ke8,Qd8,Ra8,Rh8,Bc8,Ng8,Nc6,a7,b7,c7,d7,e7,f7,h7,h6

Sample Output

+---+---+---+---+---+---+---+---+
|.r.|:::|.b.|:q:|.k.|:::|.n.|:r:|
+---+---+---+---+---+---+---+---+
|:p:|.p.|:p:|.p.|:p:|.p.|:::|.p.|
+---+---+---+---+---+---+---+---+
|...|:::|.n.|:::|...|:::|...|:p:|
+---+---+---+---+---+---+---+---+
|:::|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|...|:::|...|:::|.P.|:::|...|:::|
+---+---+---+---+---+---+---+---+
|:P:|...|:::|...|:::|...|:::|...|
+---+---+---+---+---+---+---+---+
|.P.|:::|.P.|:P:|...|:P:|.P.|:P:|
+---+---+---+---+---+---+---+---+
|:R:|.N.|:B:|.Q.|:K:|.B.|:::|.R.|
+---+---+---+---+---+---+---+---+

Source

Analysis
又是一个模拟题,首先把默认的表打出来,再按照输入的格式判断出什么位置修改成什么字母即可,
注意下标的控制,小写字母为横轴,数字为纵轴,还有默认字母为P,white为小写,black为大写。最后输出即可。
Source Code
#include <cstdio>
#include <cstring>
#include <ctype.h>
char s[20][36]= {"+---+---+---+---+---+---+---+---+","|:::|...|:::|...|:::|...|:::|...|","+---+---+---+---+---+---+---+---+","|...|:::|...|:::|...|:::|...|:::|","+---+---+---+---+---+---+---+---+","|:::|...|:::|...|:::|...|:::|...|","+---+---+---+---+---+---+---+---+","|...|:::|...|:::|...|:::|...|:::|","+---+---+---+---+---+---+---+---+","|:::|...|:::|...|:::|...|:::|...|","+---+---+---+---+---+---+---+---+","|...|:::|...|:::|...|:::|...|:::|","+---+---+---+---+---+---+---+---+","|:::|...|:::|...|:::|...|:::|...|","+---+---+---+---+---+---+---+---+","|...|:::|...|:::|...|:::|...|:::|","+---+---+---+---+---+---+---+---+"};
using namespace std;
int main()
{
    int i,l;
    char a[128],b[128],c[10],d[10];
    scanf("%s %s %s %s",c,a,d,b);
    l=(int)strlen(a);
    for (i=0; i<l; i++)
        if (islower(a[i]))
        {
            s[(a[i+1]-'1')*2+1][(a[i]-'a')*4+2]='P';
            i+=2;
        }
        else if (isupper(a[i]))
        {
            s[(a[i+2]-'1')*2+1][(a[i+1]-'a')*4+2]=a[i];
            i+=3;
        }
    l=(int)strlen(b);
    for (i=0; i<l; i++)
        if (islower(b[i]))
        {
            s[(b[i+1]-'1')*2+1][(b[i]-'a')*4+2]='p';
            i+=2;
        }
        else if (isupper(b[i]))
        {
            s[(b[i+2]-'1')*2+1][(b[i+1]-'a')*4+2]=b[i]+32;
            i+=3;
        }
    for (i=16; i>=0; i--)
        printf("%s\n",s[i]);
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值