Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 51621 Accepted: 21527

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a= "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


题意:字符串是由某个子串重复连接组成,求子串最小的长度

要充分了解next数组
next[i]表示字符串前i个字符前缀和后缀最大匹配长度

代码如下:
#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int N=1000005;
int next[N];
char s[N];
void get_next(int next[],char s[],int len)
{
    int i=0;
    int j=-1;
    next[i]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
            next[++i]=++j;
        else
            j=next[j];
    }

}
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='.')
            break;
        int len=strlen(s);
        get_next(next,s,len);
        if(len%(len-next[len])==0)
            printf("%d\n",len/(len-next[len]));
        else
            printf("1\n");
    }
    return 0;
}



Period
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 18699 Accepted: 9091

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as A K ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source



该题与上题基基本一样

代码如下:

#include <iostream>
#include <stdio.h>
#include <string.h>

using namespace std;
const int N=1000000+5;
char s[N];
int next[N];
void get_next(int next[],char s[],int len)
{
    int i=0,j=-1;
    next[0]=-1;
    while(i<len)
    {
        if(j==-1||s[i]==s[j])
            next[++i]=++j;
        else
            j=next[j];
    }
}

int main()
{
    int len;
    int ans=1;
    while(~scanf("%d",&len)&&len)
    {
        scanf("%s",s);
        get_next(next,s,len);
        printf("Test case #%d\n",ans++);
        for(int i=2;i<=len;i++)
            if(next[i]>0&&i%(i-next[i])==0)
                printf("%d %d\n",i,i/(i-next[i]));
        puts("");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值