1107 Social Clusters

1107 Social Clusters (30 分)
When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:
Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K
​i
​​ : h
​i
​​ [1] h
​i
​​ [2] … h
​i
​​ [K
​i
​​ ]

where K
​i
​​ (>0) is the number of hobbies, and h
​i
​​ [j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:
For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4
Sample Output:
3
4 3 1
题意:
有N个人,每个人喜欢若干项活动,如果两个人有任意一个活动相同,那么就称他们处于同一个社交网络(若A和B属于同一个社交网络,B和C属于同一个社交网络,那么A,B,C属于同一个社交网络),求这N个人总共形成了多少个社交网络。

#include<cstdio>
#include<algorithm>
using namespace std;
const int N=1010;
int father[N];//存放父亲结点 
int isRoot[N]={0};//记录每个结点是否作为某个集合的根结点
int course[N]={0};
int findFather(int x)
{
	int a=x;
	while(x!=father[x])
	{
		x=father[x];
	}
	while(a!=father[a])
	{
		int z=a;
		a=father[a];
		father[z]=x;
	}
	return x;
} 
void Union(int a,int b)
{
	int faA=findFather(a);
	int faB=findFather(b);
	if(faA!=faB)
	{
		father[faA]=faB;
	}
}
void init(int n)
{
	for(int i=1;i<=n;i++)
	{
		father[i]=i;
		isRoot[i]=false;
	}
}
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
	int n,k,h;
	scanf("%d",&n);
	init(n);
	for(int i=1;i<=n;i++)
	{
		//对每个人
		scanf("%d:",&k);//活动个数
		for(int j=0;j<k;j++)
		{
			scanf("%d",&h);//i号人喜欢的活动h
			if(course[h]==0)
			{
				//如果活动h第一次有人喜欢
				course[h]=i;//令i喜欢活动h 
			} 
			Union(i,findFather(course[h]));//合并
			 
		} 
	}
	for(int i=1;i<=n;i++)
	{
		isRoot[findFather(i)]++;
		//i的根结点是findFather(i),人数加1 
	} 
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		if(isRoot[i]!=0)
		{
			ans++;
		}
	} 
	printf("%d\n",ans);
	sort(isRoot+1,isRoot+n+1,cmp);
	for(int i=1;i<=ans;i++)
	{
		printf("%d",isRoot[i]);
		if(i<ans)
		printf(" ");
	}
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值