POj 3984迷宫问题(Bfs+队列)

迷宫问题

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 33803 Accepted: 19243

Description

定义一个二维数组: 

int maze[5][5] = {

	0, 1, 0, 0, 0,

	0, 1, 0, 1, 0,

	0, 0, 0, 0, 0,

	0, 1, 1, 1, 0,

	0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input

一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。

Output

左上角到右下角的最短路径,格式如样例所示。

Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

Source

源代码:

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;
struct Pos{
    int r,c;//设置行列
    int father;//设置父亲指针
    Pos(int rr=0,int cc=0,int ff=0):r(rr),c(cc),father(ff){}//构造函数
};
int maze[8][8];
Pos que[100];
int head,tail;
//设置四个方向
Pos dir[4]={Pos(-1,0),Pos(1,0),Pos(0,-1),Pos(0,1)};
int main(){
    memset(maze,1,sizeof(maze));
    for(int i=1;i<=5;i++)
        for(int j=1;j<=5;j++)
             cin>>maze[i][j];
    head=0;tail=1;
    que[0]=Pos(1,1,-1);
    while(head!=tail){
        Pos ps =que[head];
        if(ps.r==5&&ps.c==5){//队头节点是目标节点
        vector<Pos> vt;
        while(true){
            vt.push_back(Pos(ps.r,ps.c,0));//在队尾添加元素
            if(ps.father==-1)//起点
                break;
            ps=que[ps.father];
        }
        for(int i=vt.size()-1;i>=0;--i)
            //因为输出是从(0,0)开始的
            cout<<"("<<vt[i].r-1<<", "<<vt[i].c-1<<")"<<endl;
        return 0;
        }
        else{//如果不是一次就找到的情况
            int r=ps.r,c=ps.c;
            for(int i=0;i<4;i++)
                if(!maze[r+dir[i].r][c+dir[i].c]){//向四个方向查找,不为1的执行入队操作
                    que[tail++]=Pos(r+dir[i].r,c+dir[i].c,head);
                    maze[r+dir[i].r][c+dir[i].c]=1;
                }
                ++head;//头指针不断向前滚动
        }
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值